configuring * to send email...

Get help with installing, upgrading and running Asterisk.

Moderators: muppetmaster, Support, Moderator

configuring * to send email...

Postby solarix » Wed Jan 11, 2006 1:26 am

hi all! i was just configuring asterisk voicemail and it works just fine, my only problem is configuring it to send email notification if there are new messages. i've edited voicemail.conf and also included existing e-adds on my clients. what else do i have to configure for me to succeed, coz right now i'm checking the email add that i've included but there's no new messages, configured emalsubject and emailbody too...anyone who can help me with this or direct me to something that i can read on?..:)
-- Jerry
solarix
Oldsterisk
 
Posts: 55
Joined: Thu Dec 21, 2006 10:56 pm

Postby muppetmaster » Wed Jan 11, 2006 1:41 am

Are you able to connect to your local SMTP server (ie - Postfix/Sendmail) and send an email to one of the addresses in /etc/voicemail.conf manually?
muppetmaster
Salt of the Asterisk
 
Posts: 1081
Joined: Thu Dec 21, 2006 10:56 pm
Location: San Carlos, CA

...

Postby solarix » Wed Jan 11, 2006 1:58 am

hi, i've started sendmail but i don't know what will i configure, can you help me on how to configure my smtp server? :)
-- Jerry
solarix
Oldsterisk
 
Posts: 55
Joined: Thu Dec 21, 2006 10:56 pm

Re: ...

Postby muppetmaster » Wed Jan 11, 2006 3:12 am

ryanalupa wrote:hi, i've started sendmail but i don't know what will i configure, can you help me on how to configure my smtp server? :)


Unfortunately that is outside of the scope of Asterisk itself, I would recommend having a look around Sendmail:

http://www.sendmail.org/

Also, Postfix might be easier for you, especially if you are just setting this up for Asterisk emailing.
muppetmaster
Salt of the Asterisk
 
Posts: 1081
Joined: Thu Dec 21, 2006 10:56 pm
Location: San Carlos, CA

Postby IAX Man » Sun Mar 05, 2006 7:36 pm

Hi, Sendmail should already be running and no need to change the configuration on it.

You need to do the following:

1. Wirte down the email address you are trying to send the email notifiation to. i.e. peter@abc.com

2. Open your console not asterisk CLI, but Linux CLI. Then run the following command:
nslookup abc.com
Make sure that the IP address that it returns is in deed the correct IP address for that mail server.

3. If this is not correct you aree more than likely usgin your internal DNS servers to resolve the domain name it will tryto route all your emails to your local server instead of your exten mail server (if you have one). You need to go into /etc/resolv.conf and change the IP address for the name server in there to your ISP instead of internal DNS server.

4. Restart and test.

5. If this does not work then you need to go into your /etc/hosts file and add your DNS domain in there: pbx.abc.com


Let me know if this helps
Best,
Rene
IAX Man
Newsterisk
 
Posts: 15
Joined: Thu Dec 21, 2006 10:56 pm

Postby bxjy » Tue Mar 07, 2006 1:51 pm

Are you able to connect to your local SMTP server (ie - Postfix/Sendmail) and send an email to one of the addresses in /etc/voicemail.conf manually?

I tried the ssmtp command ,but it said invalid response SMTP server, what does that mean?
bxjy
Oldsterisk
 
Posts: 118
Joined: Thu Dec 21, 2006 10:56 pm

Postby NPinkerton » Fri Jul 21, 2006 4:19 pm

The system I am setting up right now (for testing and personal use) is on a residential internet connection.
The ISP blocks ports needed for running a local SMTP server. Is there a way (that I have overlooked) to configure Asterisk to use my ISP's SMTP server to email voicemail messages?

Or do I just need to change the port on which SendMail operates?


nevermind... I found my answer... I think... I am gonna give ssmtp a try.
If, at first, you do not succeed, get a bigger hammer.
NPinkerton
Newsterisk
 
Posts: 13
Joined: Thu Dec 21, 2006 10:56 pm

use the link below as a guide

Postby bubba » Fri Jul 21, 2006 5:18 pm

bubba
Oldsterisk
 
Posts: 268
Joined: Thu Dec 21, 2006 10:56 pm

Postby NPinkerton » Fri Jul 21, 2006 6:38 pm

I'm an idiot... I posted this question before really thinking about it... my ISP only blocks incoming port 25, not outgoing... sendmail will do exactly what I need. I'm sorry to have wasted your time.
If, at first, you do not succeed, get a bigger hammer.
NPinkerton
Newsterisk
 
Posts: 13
Joined: Thu Dec 21, 2006 10:56 pm

[HELP] configuring * to send email...

Postby proxyfrog1 » Sun Jul 30, 2006 10:30 am

I'm having the same problem:
I can send out email if I'm doing it through webmin, works just fine......but when i have a voicemail to send out of asterisk I get a 530 authentication required back.

I went into my asterisk mailbox and found it's still a user authentication error.
How is it that authentication is ok when emailing out with just webmin and fails when using asterisk?

I'm guessing its somewhere in asterisk....can someone suggest places to check please? Maybe it's some email config in asterisk? I'm starting to think I may have compiled sasl with incomplete parameters and thus excluded asterisk in the process....is this possible?
proxyfrog1
Newsterisk
 
Posts: 4
Joined: Thu Dec 21, 2006 10:56 pm

[RESOLVED] configuring * to send email...

Postby proxyfrog1 » Fri Aug 04, 2006 7:42 am

turns out my isp changed its smtp ip address on me. I've found out the correct ip address and now everything's cool.
proxyfrog1
Newsterisk
 
Posts: 4
Joined: Thu Dec 21, 2006 10:56 pm


Return to Asterisk Support

Who is online

Users browsing this forum: bmhlanga and 27 guests