IAX Client doesn't ring on outbound call

Get help with installing, upgrading and running Asterisk.

Moderators: muppetmaster, Moderator, Support

IAX Client doesn't ring on outbound call

Postby mpiontek » Mon Aug 15, 2011 7:07 am

I have one user who uses Voix Phone and does not hear any ringing/progress on outbound calls. I have been searching and do not see anything like adding progress to the iax.conf, etc.

Is this a common issue and I'm just not using the right search terms?

EDIT:
It's probably helpful to mention that the call goes out through a dahdi (PRI) trunk.
Mark
IT Director
Milwaukee, Wisconsin
mpiontek
Oldsterisk
 
Posts: 57
Joined: Thu Dec 21, 2006 10:56 pm

Re: IAX Client doesn't ring on outbound call

Postby david55 » Mon Aug 15, 2011 8:07 am

Is this robbed bit signalling? I'm not sure that would provide answer supervision, and without answer supervision, Asterisk has to assume an immediate answer, so can't generate ring back tone itself.
david55
Moves Like Spencer
 
Posts: 12570
Joined: Fri Sep 26, 2008 5:03 am

Re: IAX Client doesn't ring on outbound call

Postby mpiontek » Mon Aug 15, 2011 8:52 am

So, IAX clients generally don't hear ringing, or is this more likely related specifically to my asterisk configuration?
Mark
IT Director
Milwaukee, Wisconsin
mpiontek
Oldsterisk
 
Posts: 57
Joined: Thu Dec 21, 2006 10:56 pm

Re: IAX Client doesn't ring on outbound call

Postby david55 » Mon Aug 15, 2011 8:55 am

Nothing to do with IAX.

You will not hear ring back on PSTN calls unless the PSTN generates it, or there is answer supervision and Asterisk knows about the answer supervision.

Without answer supervision, Asterisk treats the call as answered immediately after dialing and passes through audio from the PSTN.
david55
Moves Like Spencer
 
Posts: 12570
Joined: Fri Sep 26, 2008 5:03 am

Re: IAX Client doesn't ring on outbound call

Postby mpiontek » Mon Aug 15, 2011 9:12 am

SIP clients hear ringing, it's just the IAX client that does not. Searching for answer supervision references disconnect supervision. All calls are going out a PRI and I thought disconnect supervision was for analog channels, so I'm kind of stumped here.

In this situation should I just tell asterisk to provide ringing - or what's the best solution?

I may just have to find a SIP softphone for this person.

I appreciate your responding, David.

Thanks.
Mark
IT Director
Milwaukee, Wisconsin
mpiontek
Oldsterisk
 
Posts: 57
Joined: Thu Dec 21, 2006 10:56 pm

Re: IAX Client doesn't ring on outbound call

Postby david55 » Mon Aug 15, 2011 9:25 am

Being IAX specific suggests an IAX problem. You need to provide verbose console log traces, initially, and possibly detailed IAX and DAHDI debug logging, later.

Answer and disconnect supervision applies to everything. Analogue channels often lack it. Common channel signalling is pretty much certain to have it. However, PRI, on its own, implies channel associated signalling, which may well not have it.

http://www.cisco.com/en/US/tech/tk652/t ... 2560.shtml contains some information on T1 robbed bit signalling options, and specifically says supervision may not be available.
david55
Moves Like Spencer
 
Posts: 12570
Joined: Fri Sep 26, 2008 5:03 am


Return to Asterisk Support

Who is online

Users browsing this forum: No registered users and 20 guests