Registration failed - Device does not match ACL

Get help with installing, upgrading and running Asterisk.

Moderators: muppetmaster, Moderator, Support

Registration failed - Device does not match ACL

Postby randell » Thu Apr 19, 2012 1:50 pm

The example under https://wiki.asterisk.org/wiki/display/ ... ctionality worked perfectly on my local machine with Twinkle. However, when I deployed Asterisk on another machine within the same network, I got the following message:

Code: Select all
chan_sip.c:25761 handle_request_register: Registration from '"demo-alice" <sip:demo-alice@XXX.XXX.XXX.XXX>' failed for 'YYY.YYY.YYY.YYY' - Device does not match ACL


Here is the configuration I appended to sip.conf:

Code: Select all
[demo-alice]
type=friend
host=dynamic
secret=verysecretpassword ; put a strong, unique password here instead
context=users
deny=0.0.0.0/0
permit=XXX.XXX.XXX.XXX/255.255.255.0 ; replace with your network settings

[demo-bob]
type=friend
host=dynamic
secret=othersecretpassword ; put a strong, unique password here instead
context=users
deny=0.0.0.0/0
permit=XXX.XXX.XXX.XXX/255.255.255.0 ; replace with your network settings


And here is the configuration I appended to extensions.conf:

Code: Select all
[users]
exten => 6001,1,Dial(SIP/demo-alice,20)
exten => 6002,1,Dial(SIP/demo-bob,20)
exten => 6598,1,Goto(demo-menu,s,1)
exten => 6599,1,Goto(day-menu,s,1)
exten => 6597,1,Answer(500)
   same => n,Record(en/custom-menu.gsm)
   same => n,Wait(1)
   same => n,Playback(custom-menu)
   same => n,Hangup()

[demo-menu]
exten => s,1,Answer(500)
   same => n(loop),Background(press-1&or&press-2)
   same => n,WaitExten()

exten => 1,1,Playback(you-entered)
   same => n,SayNumber(1)
   same => n,Goto(s,loop)

exten => 2,1,Playback(you-entered)
   same => n,SayNumber(2)
   same => n,Goto(s,loop)

exten => i,1,Playback(option-is-invalid)
   same => n,Goto(s,loop)

exten => t,1,Playback(are-you-still-there)
   same => n,Goto(s,loop)

[day-menu]
exten => s,1,Answer(500)
same => n(loop),Background(custom-menu)
same => n,WaitExten()

exten => 1,1,Goto(users,6001,1)

exten => 2,1,Goto(users,6002,1)

exten => 9,1,Directory(vm-demo,users,fe)
exten => *,1,VoiceMailMain(@vm-demo)

exten => i,1,Playback(option-is-invalid)
same => n,Goto(s,loop)

exten => t,1,Playback(are-you-still-there)
same => n,Goto(s,loop)


Which parts am I supposed to change to make it work for this setup?

I'm using Asterisk 10.3.0.
Last edited by randell on Thu Apr 19, 2012 10:41 pm, edited 1 time in total.
randell
Newsterisk
 
Posts: 7
Joined: Tue Apr 10, 2012 1:08 am

Re: Registration failed - Device does not match ACL

Postby david55 » Thu Apr 19, 2012 2:53 pm

There should be four groups of digits in an IP address.
david55
Moves Like Spencer
 
Posts: 10591
Joined: Fri Sep 26, 2008 5:03 am

Re: Registration failed - Device does not match ACL

Postby zz554433 » Thu Apr 19, 2012 4:00 pm

For single IP permission
permit=XXX.XXX.XXX./255.255.255.0 ; replace with your network settings

you need to give the IP address as: permit=XXX.XXX.XXX.XXX/255.255.255.0
zz554433
Newsterisk
 
Posts: 7
Joined: Thu Apr 19, 2012 3:44 pm

Re: Registration failed - Device does not match ACL

Postby randell » Thu Apr 19, 2012 10:43 pm

david55 wrote:There should be four groups of digits in an IP address.

Thanks. I have corrected my typo.
randell
Newsterisk
 
Posts: 7
Joined: Tue Apr 10, 2012 1:08 am

Re: Registration failed - Device does not match ACL

Postby randell » Thu Apr 19, 2012 10:56 pm

zz554433 wrote:For single IP permission
permit=XXX.XXX.XXX./255.255.255.0 ; replace with your network settings

you need to give the IP address as: permit=XXX.XXX.XXX.XXX/255.255.255.0


Thanks!

I replaced the first parameter for permit with the IP address of the other machine using Twinkle. Is that correct? On that note, how do I give multiple IP permission?

Now I'm getting a dialog box saying "Login required for realm: asterisk", with two fields asking for a "User name" and "Password". What values am I supposed to enter in those fields? Are they specified anywhere in the SIP configuration?
randell
Newsterisk
 
Posts: 7
Joined: Tue Apr 10, 2012 1:08 am

Re: Registration failed - Device does not match ACL

Postby eg » Fri Apr 20, 2012 2:58 am

Hello randell ,
you need now to play with twinkle configuration,
Remove whatever you set in Realm text box.
basically you will need just this information , bu it depends on your server configuration.
In user tab enter following information :
Code: Select all
User Name : <Phone Extension>
Domain : <SIP Domain>
Authentication Name  : <Your Phone Extension>
Password : <Your password>


In SIP server tab.
Code: Select all
Registar : <SIP Domain>


Good luck !
eg
Newsterisk
 
Posts: 41
Joined: Fri Mar 26, 2010 3:49 am


Return to Asterisk Support

Who is online

Users browsing this forum: Google [Bot], sart81, thesin and 56 guests