Asterisk 13 “ __set_address_from_contact: Invalid contact ur

Get help with installing, upgrading and running Asterisk.

Moderators: muppetmaster, Moderator, Support

Asterisk 13 “ __set_address_from_contact: Invalid contact ur

Postby anthonygill08 » Wed May 13, 2015 11:59 am

I'm installing Asterisk 13 on our production Ubuntu 14.0.4 box and the process seemed to go well. I previously installed it on my personal server as well. It works perfectly on my personal server, but on the production server, I periodically get this error:

Code: Select all
[May 11 17:48:43] WARNING[6754]: chan_sip.c:16110 __set_address_from_contact: Invalid contact uri  (missing sip: or sips:), attempting to use anyway
[May 11 17:48:43] WARNING[6754]: chan_sip.c:16123 __set_address_from_contact: Invalid URI: parse_uri failed to acquire hostport
[May 11 17:48:43] WARNING[14673]: file.c:905 ast_readaudio_callback: Failed to write frame
[May 11 17:48:43] WARNING[14673]: app_playback.c:493 playback_exec: Playback failed on SIP/vitel-outbound-00000003 for tt-monkeys


To get the error, I'm running asterisk -rvvvvv and then running the command below to test:

Code: Select all
channel originate SIP/vitel-outbound/15554443333 application Playback tt-monkeys


The first or second time I attempt the call, it works - my phone rings and I'm assaulted by monkey screams. Usually the third or fourth time, however, I get the error shown above. My phone does ring, but then it immediately hangs up when I answer.

If I exit asterisk and do a sudo service asterisk restart, everything goes back to being healthy for a few calls.

My only other observation is that in the failure cases, it tends to take a while before my phone rings. When it works, I'll send the command and my phone will ring a few seconds later.

Any suggestions? I'm stumped.
anthonygill08
Newsterisk
 
Posts: 1
Joined: Wed May 13, 2015 11:58 am

Re: Asterisk 13 “ __set_address_from_contact: Invalid contact ur

Postby david55 » Wed May 13, 2015 2:32 pm

The error is in what is being sent by the peer. You need sip debugging to see what it is doing wrong.
david55
Moves Like Spencer
 
Posts: 12570
Joined: Fri Sep 26, 2008 5:03 am

Re: Asterisk 13 “ __set_address_from_contact: Invalid contact ur

Postby remon4944 » Thu May 14, 2015 6:08 am

You should review the "REGISTER Sip" package > headers > Contact URI .
Surely that's the problem.
Contact URI field, should be formatted as follows:
<Sip: user@x.x.x.x: port>


Greetings.
Excuse my English
remon4944
Newsterisk
 
Posts: 2
Joined: Wed May 13, 2015 7:20 am

Re: Asterisk 13 “ __set_address_from_contact: Invalid contact ur

Postby david55 » Wed May 20, 2015 3:43 pm

It's complaining about an incoming contact header, not one that Asterisk is sending. Also "REGISTER Sip" package > headers > Contact URI" looks like instructions for using some sort of third party GUI.
david55
Moves Like Spencer
 
Posts: 12570
Joined: Fri Sep 26, 2008 5:03 am


Return to Asterisk Support

Who is online

Users browsing this forum: Google [Bot] and 1 guest