Error sending STUN request: Invalid argument

Get help with installing, upgrading and running Asterisk.

Moderators: muppetmaster, Moderator, Support

Error sending STUN request: Invalid argument

Postby flobou » Wed Oct 07, 2015 3:01 am


I'm currently trying to make a call from sipml5 live demo ( to a softphone. But there is no audio from the sipml5 to the softphone.
I'm using Asterisk 13.2.0 and get the error:
Code: Select all
Error sending STUN request: Invalid argument

I tried with Asterisk 13.5.0 as well but didn't solve the issue.
My peer is define as:
Code: Select all
[1061] ; This will be WebRTC client
username=1061 ; The Auth user for SIP.js
host=dynamic ; Allows any host to register
secret=1061 ; The SIP Password for SIP.js
encryption=yes ; Tell Asterisk to use encryption for this peer
avpf=yes ; Tell Asterisk to use AVPF for this peer
icesupport=yes ; Tell Asterisk to use ICE for this peer
context=default ; Tell Asterisk which context to use when this peer is dialing
directmedia=no ; Asterisk will relay media for this peer
transport=udp,ws ; Asterisk will allow this peer to register on UDP or WebSockets
force_avp=yes ; Force Asterisk to use avp. Introduced in Asterisk 11.11
dtlsenable=yes ; Tell Asterisk to enable DTLS for this peer
dtlsverify=no ; Tell Asterisk to not verify your DTLS certs
dtlscertfile=/etc/asterisk/keys/asterisk.pem ; Tell Asterisk where your DTLS cert file is
dtlsprivatekey=/etc/asterisk/keys/asterisk.pem ; Tell Asterisk where your DTLS private key is
dtlssetup=actpass ; Tell Asterisk to use actpass SDP parameter when setting up DTLS

I try to remove the nat setting and to set it globally without success.

I set in sip.conf and rtp.conf:
Code: Select all
stunaddr =

I try to apply the patch but didn't solve the issue either: ... role.patch

Does someone had this issue and solved it?

Posts: 3
Joined: Tue Oct 28, 2014 9:09 am

Return to Asterisk Support

Who is online

Users browsing this forum: Google [Bot] and 1 guest