Cisco 7941 can't dial

Get help with installing, upgrading and running Asterisk.

Moderators: muppetmaster, Moderator, Support

Cisco 7941 can't dial

Postby tremols » Sat Oct 10, 2015 10:34 am

I have been 3 days configuring a Cisco 7941 to work with Asterisk
The telephone registers fine. It can receive calls from a soft-phone.
Two soft-phones can communicate perfectly

I CAN'T DIAL FROM THE CISCO TO THE SOFT-PHONE

The only difference that I find is on the Wireshark capture of the communication initiated from the soft-phone and the one initiated from the cisco.

I'm almost sure that the problem originates on the way that cisco tries to begin the connection as on the capture it looks different. Maybe something on the SEPMAC.cnf.xml file. Here is the capture:

For CISCO
Request: INVITE sip:1001@192.168.200.5;user=phone |
Request: ACK sip:1001@192.168.200.5;user=phone |

For the soft-phone
Request: INVITE sip:1000@192.168.200.5 |
Request: ACK sip:1000@192.168.200.5 |

Here is my SEPMAC.cnf.xml file

<device>
<deviceProtocol>SIP</deviceProtocol>

<!-- Nom d'utilisateur et mot de passe pour la connexion SSH. -->
<sshUserId>admin</sshUserId>
<sshPassword>cisco</sshPassword>

<devicePool>

<!-- Format de date, fuseau horaire et serveur NTP. -->
<dateTimeSetting>
<dateTemplate>D/M/YY</dateTemplate>
<timeZone>Eastern Standard/Daylight Time</timeZone>
<ntps>
<ntp>
<name>xxx.xxx.xxx.xxx</name>
<ntpMode>Unicast</ntpMode>
</ntp>
</ntps>
</dateTimeSetting>

<!-- Serveur Asterisk -->
<callManagerGroup>
<members>
<member priority="0">
<callManager>
<ports>
<ethernetPhonePort>2000</ethernetPhonePort>
<sipPort>5060</sipPort>
<securedSipPort>5061</securedSipPort>
</ports>
<processNodeName>192.168.200.5</processNodeName>
</callManager>
</member>
</members>
</callManagerGroup>

</devicePool>
<sipProfile>
<sipProxies>
<backupProxy></backupProxy>
<backupProxyPort>5060</backupProxyPort>
<emergencyProxy></emergencyProxy>
<emergencyProxyPort></emergencyProxyPort>
<outboundProxy></outboundProxy>
<outboundProxyPort></outboundProxyPort>
<registerWithProxy>true</registerWithProxy>
</sipProxies>
<sipCallFeatures>
<cnfJoinEnabled>true</cnfJoinEnabled>
<callForwardURI>x-serviceuri-cfwdall</callForwardURI>
<callPickupURI>x-cisco-serviceuri-pickup</callPickupURI>
<callPickupListURI>x-cisco-serviceuri-opickup</callPickupListURI>
<callPickupGroupURI>x-cisco-serviceuri-gpickup</callPickupGroupURI>
<meetMeServiceURI>x-cisco-serviceuri-meetme</meetMeServiceURI>
<abbreviatedDialURI>x-cisco-serviceuri-abbrdial</abbreviatedDialURI>
<rfc2543Hold>false</rfc2543Hold>
<callHoldRingback>2</callHoldRingback>
<localCfwdEnable>true</localCfwdEnable>
<semiAttendedTransfer>true</semiAttendedTransfer>
<anonymousCallBlock>2</anonymousCallBlock>
<callerIdBlocking>2</callerIdBlocking>
<dndControl>0</dndControl>
<remoteCcEnable>true</remoteCcEnable>
</sipCallFeatures>
<sipStack>
<sipInviteRetx>6</sipInviteRetx>
<sipRetx>10</sipRetx>
<timerInviteExpires>180</timerInviteExpires>
<timerRegisterExpires>3600</timerRegisterExpires>
<timerRegisterDelta>5</timerRegisterDelta>
<timerKeepAliveExpires>120</timerKeepAliveExpires>
<timerSubscribeExpires>120</timerSubscribeExpires>
<timerSubscribeDelta>5</timerSubscribeDelta>
<timerT1>500</timerT1>
<timerT2>4000</timerT2>
<maxRedirects>70</maxRedirects>
<remotePartyID>false</remotePartyID>
<userInfo>None</userInfo>
</sipStack>
<autoAnswerTimer>1</autoAnswerTimer>
<autoAnswerAltBehavior>false</autoAnswerAltBehavior>
<autoAnswerOverride>true</autoAnswerOverride>
<transferOnhookEnabled>false</transferOnhookEnabled>
<enableVad>false</enableVad>

<!-- Preferred codec for SIP. -->
<preferredCodec>g729a</preferredCodec>

<dtmfAvtPayload>101</dtmfAvtPayload>
<dtmfDbLevel>3</dtmfDbLevel>
<dtmfOutofBand>avt</dtmfOutofBand>
<alwaysUsePrimeLine>false</alwaysUsePrimeLine>
<alwaysUsePrimeLineVoiceMail>false</alwaysUsePrimeLineVoiceMail>
<kpml>3</kpml>

<!-- Intitulé du téléphone - 10 caractères max -->
<phoneLabel>JOSE</phoneLabel>

<stutterMsgWaiting>1</stutterMsgWaiting>
<callStats>false</callStats>
<silentPeriodBetweenCallWaitingBursts>10</silentPeriodBetweenCallWaitingBursts>
<disableLocalSpeedDialConfig>false</disableLocalSpeedDialConfig>

<!-- Configuration des lignes du téléphone -->
<sipLines>
<line button="1">
<featureID>9</featureID>
<!-- Nom du bouton -->
<featureLabel>Asterisk</featureLabel>
<!-- Version 9.4.2: Inscrire USECALLMANAGER -->
<proxy>USECALLMANAGER</proxy>
<port>5060</port>

<!-- Numéro de poste -->
<name>1000</name>
<!-- Nom du poste -->
<displayName>Jose</displayName>

<!-- Nom d'utilisateur et mot de passe Asterisk -->
<authName>1000</authName>
<authPassword>1234</authPassword>

<autoAnswer>
<autoAnswerEnabled>2</autoAnswerEnabled>
</autoAnswer>
<callWaiting>3</callWaiting>
<sharedLine>false</sharedLine>
<messageWaitingLampPolicy>1</messageWaitingLampPolicy>

<!-- Numéro de téléphone de la boîte vocale -->
<messagesNumber>*99</messagesNumber>

<ringSettingIdle>4</ringSettingIdle>
<ringSettingActive>5</ringSettingActive>

<!-- Numéro de poste -->
<contact>1000</contact>

<forwardCallInfoDisplay>
<callerName>true</callerName>
<callerNumber>false</callerNumber>
<redirectedNumber>false</redirectedNumber>
<dialedNumber>true</dialedNumber>
</forwardCallInfoDisplay>
</line>
<line button="2">
<featureID>20</featureID>
<featureLabel>Menu</featureLabel>
<serviceURI>http://example.domain.ext/services/menu.xml</serviceURI>
</line>
</sipLines>

<natEnabled>false</natEnabled>
<voipControlPort>5060</voipControlPort>
<startMediaPort>16348</startMediaPort>
<stopMediaPort>20134</stopMediaPort>
<dscpForAudio>184</dscpForAudio>

<ringSettingBusyStationPolicy>0</ringSettingBusyStationPolicy>

<!-- Fichiers XML du plan de numérotation et des boutons virtuels -->
<dialTemplate>dialplan.xml</dialTemplate>
<softKeyFile>softkeys.xml</softKeyFile>
</sipProfile>
<commonProfile>

<!-- Mot de passe de verrouillage des réglages -->
<phonePassword></phonePassword>

<backgroundImageAccess>true</backgroundImageAccess>
<callLogBlfEnabled>2</callLogBlfEnabled>
</commonProfile>

<!-- Version du logiciel à télécharger -->
<loadInformation>SIP41.9-4-2SR1-1S</loadInformation>

<vendorConfig>
<disableSpeaker>false</disableSpeaker>
<disableSpeakerAndHeadset>false</disableSpeakerAndHeadset>
<pcPort>0</pcPort>

<!-- Accès aux réglages: 0 Non, 1 Oui -->
<settingsAccess>1</settingsAccess>

<garp>0</garp>
<voiceVlanAccess>0</voiceVlanAccess>
<videoCapability>0</videoCapability>
<autoSelectLineEnable>0</autoSelectLineEnable>

<!-- Accès à l'interface Web: 0 Oui, 1 Non -->
<webAccess>0</webAccess>

<!-- Accès à l'interface SSH: 0 Oui, 1 Non -->
<sshAccess>0</sshAccess>

<daysDisplayNotActive>1,2,3,4,5,6,7</daysDisplayNotActive>
<displayOnTime>00:00</displayOnTime>
<displayOnDuration>00:00</displayOnDuration>
<displayIdleTimeout>00:00</displayIdleTimeout>
<spanToPCPort>1</spanToPCPort>
<loggingDisplay>1</loggingDisplay>
<loadServer></loadServer>
</vendorConfig>

<!-- Pack de langages à installer. -->
<userLocale>
<name>America_United_States</name>
<uid>1</uid>
<langCode>en_US</langCode>
<version>10.3(2)</version>
<winCharSet>iso-8859-1</winCharSet>
</userLocale>

<!-- Localisation régionale à installer -->
<networkLocale>United_States</networkLocale>
<networkLocaleInfo>
<name>United_States</name>
<uid>1</uid>
<version>10.3(2)</version>
</networkLocaleInfo>

<deviceSecurityMode>1</deviceSecurityMode>
<authenticationURL>http://example.domain.ext/services/authenticate.php</authenticationURL>
<directoryURL>http://example.domain.ext/services/directory.php</directoryURL>
<servicesURL>http://example.domain.ext/services/menu.xml</servicesURL>
<idleURL></idleURL>
<informationURL></informationURL>
<messagesURL></messagesURL>
<proxyServerURL></proxyServerURL>

<dscpForSCCPPhoneConfig>96</dscpForSCCPPhoneConfig>
<dscpForSCCPPhoneServices>0</dscpForSCCPPhoneServices>
<dscpForCm2Dvce>96</dscpForCm2Dvce>

<!-- Protocole à utiliser: 1 TCP, 2 UDP, 4 TCP ou UDP -->
<transportLayerProtocol>2</transportLayerProtocol>

<capfAuthMode>0</capfAuthMode>
<capfList>
<capf>
<phonePort>3804</phonePort>
</capf>
</capfList>
<certHash></certHash>
<encrConfig>false</encrConfig>
</device>
tremols
Newsterisk
 
Posts: 1
Joined: Sat Oct 10, 2015 10:19 am

Return to Asterisk Support

Who is online

Users browsing this forum: No registered users and 18 guests