Asterisk 13.6.0 - No matching endpoints found

Get help with installing, upgrading and running Asterisk.

Moderators: muppetmaster, Moderator, Support

Asterisk 13.6.0 - No matching endpoints found

Postby skek » Mon Dec 21, 2015 1:17 pm

I am now to asterisk. Installed Asterisk from source on Debian 8.2.

I have a sample pjsip.conf and extensions.conf with trunk to callcentric and sip phone. I am not able to receive and make call with callcentric. Here are the logs captured.



Debian1*CLI> core set debug 4
Core debug was OFF and is now 4.

Receving ingoing call:

[2015-12-21 11:33:54] NOTICE[1345]: res_pjsip/pjsip_distributor.c:347 log_unidentified_request: Request from '<sip:519xxxxxxx@204.11.194.10>' failed for '204.11.192.170:5060' (callid: 4d01bf2f632ecfe911b4aa583572758c@204.11.194.10) - No matching endpoint found

Making outgoing call:

-- Executing [17771234567@internal:1] Dial("PJSIP/6001-00000000", "PJSIP/17771234567@1777xxxxxxx") in new stack
-- Called PJSIP/17771234567@1777xxxxxxx
== Everyone is busy/congested at this time (1:0/0/1)
-- Auto fallthrough, channel 'PJSIP/6001-00000000' status is 'CHANUNAVAIL'

Asterisk 13.6.0

pjsip.conf

;==============TRANSPORTS

[simpletrans]
type=transport
protocol=udp
bind=0.0.0.0

;===============TRUNK

[callcentric]
type=registration
transport=simpletrans
outbound_auth=callcentric-auth
server_uri=sip:callcentric.com
client_uri=sip:1777xxxxxxx@callcentric.com
contact_user=1777xxxxxxx
retry_interval=60

[callcentric-auth]
type=auth
auth_type=userpass
password=xxxxxxxxx
username=1777xxxxxxx
;realm=callcentric.com

[callcentric-aor]
type=aor
contact=sip:204.11.192.170:5060

[1777xxxxxxx]
type=endpoint
transport=simpletrans
context=from-external
disallow=all
allow=ulaw
outbound_auth=callcentric-auth
aors=callcentric-aor
;redirect_method=user

[callcentric-identify]
;type=identify
;endpoint=1777xxxxxxx
;match=204.11.192.170

;===============EXTENSION 6001

[6001]
type=endpoint
context=internal
disallow=all
allow=ulaw
transport=simpletrans
auth=auth6001
aors=6001

[auth6001]
type=auth
auth_type=userpass
password=6001
username=6001

[6001]
type=aor
max_contacts=1

extensions.conf

[from-external]
;exten => s,1,Dial(PJSIP/6001)
exten => s,1,Log(WARNING, Call via trunk: from ${EXTEN})
same => n,Answer()
same => n,SayDigits(${EXTEN})
same => n,Hangup()

[internal]
exten => _XX.,1,Dial(PJSIP/${EXTEN}@1777xxxxxxx)
skek
Newsterisk
 
Posts: 2
Joined: Mon Dec 21, 2015 12:59 pm

Re: Asterisk 13.6.0 - Unable to make outgoing call

Postby skek » Thu Dec 24, 2015 5:20 pm

Note: Moderator, please help to move this post from AsteriskNow support to Asterisk support.

I have made changes to the pjsip.conf and extensions.conf after getting better understanding of the configuration settings. I am able to receive incoming call now but still unable to make outgoing call. It looks like the trunk registered to callcentric successfully but failed to authenticate when making outgoing call. Please advise if someone can point out possible issues based the conf files. The .conf files are as below.

pjsip.conf
[transport-udp]
type=transport
protocol=udp
bind=0.0.0.0:5060

[callcentric]
type=registration
transport=transport-udp
outbound_auth=callcentric
retry_interval=60
max_retries=10
expiration=3600
auth_rejection_permanent=yes
server_uri=sip:callcentric.com:5060
client_uri=sip:1777xxxxxxx@callcentric.com:5060

[callcentric]
type=endpoint
transport=transport-udp
context=from-pstn
disallow=all
allow=ulaw
outbound_auth=callcentric
aors=callcentric

[callcentric]
type=auth
auth_type=userpass
password=password
username=1777xxxxxxx

[callcentric]
type=aor
qualify_frequency=60
contact=sip:callcentric.com:5060

[callcentric]
type=identify
endpoint=callcentric
match=callcentric.com

[6001]
type=endpoint
aors=6001
auth=6001-auth
allow=ulaw
context=from-internal

[6001-auth]
type=auth
auth_type=userpass
password=6001
username=6001

[6001]
type=aor
max_contacts=1
qualify_frequency=60

extensions.conf
[from-internal]
exten => _1777XXXXXXX,1,Dial(PJSIP/${EXTEN}@callcentric)

[from-pstn]
exten => s,1,Dial(PJSIP/6001)
skek
Newsterisk
 
Posts: 2
Joined: Mon Dec 21, 2015 12:59 pm


Return to Asterisk Support

Who is online

Users browsing this forum: Exabot [Bot], Google [Bot] and 1 guest

cron