Asterisk 13.6 Segfault No Core Dump

Get help with installing, upgrading and running Asterisk.

Moderators: muppetmaster, Moderator, Support

Asterisk 13.6 Segfault No Core Dump

Postby neilsunerton » Tue Dec 22, 2015 7:06 am

I'm having some problem with a couple of Asterisk 13.6 installations where Asterisk segfaults a few times per day but I cannot get it to drop core (either that or it's hiding it somewhere by not putting it in an obvious place and not including the text "core" as part of the file name).

/var/log/messages
Code: Select all
Dec 22 12:32:52 ctx17 kernel: asterisk[29076]: segfault at c0 ip 00000000004cefdb sp 00007f65dc56a610 error 4 in asterisk[400000+35c000]
Dec 22 12:32:52 ctx17 safe_asterisk[15361]: Asterisk ended with exit status 139
Dec 22 12:32:52 ctx17 safe_asterisk[15361]: Asterisk exited on signal 11.
Dec 22 12:32:52 ctx17 safe_asterisk[15361]: Automatically restarting Asterisk.


OS is CentOS release 6.6 (Final) Linux ctx17.htel.co.uk 2.6.32-504.30.3.el6.x86_64 #1 SMP Wed Jul 15 10:13:09 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux. Asterisk is Asterisk 13.6.0 built by root @ _____ on a x86_64 running Linux on 2015-12-02 15:35:10 UTC and is started via service asterisk start.

/etc/sysconfig/asterisk contains
Code: Select all
COREDUMP=yes


/etc/asterisk/asterisk.conf contains
Code: Select all
[options]
dumpcore = yes                  ; Dump core on crash (same as -g at startup).


/usr/sbin/safe_asterisk contains
Code: Select all
ulimit -c unlimited


ps aux | grep asterisk
Code: Select all
root     14268 34.3  1.6 2677660 133572 pts/0  Sl   12:32   8:59 /usr/sbin/asterisk -f -vvvg -c
root     14269  0.0  0.0  13896   472 pts/0    S    12:32   0:00 astcanary /var/run/asterisk/alt.asterisk.canary.tweet.tweet.tweet 14268
root     15373  0.0  0.0 108212   932 pts/0    S    Dec21   0:00 /bin/sh /usr/sbin/safe_asterisk
root     18886  0.0  0.0 103256   848 pts/0    S+   12:59   0:00 grep asterisk


Build options:
Code: Select all
Compiler Flags       [*] DONT_OPTIMIZE
                     [*] LOADABLE_MODULES
                     [*] BETTER_BACKTRACES
                     [*] BUILD_NATIVE


I think/hope I've got everything set right. Does anyone have any ideas?

Many thanks,

Neil Sunerton
neilsunerton
Newsterisk
 
Posts: 6
Joined: Mon Oct 26, 2015 11:05 am

Re: Asterisk 13.6 Segfault No Core Dump

Postby david55 » Tue Dec 22, 2015 7:21 am

Are you running it non-root?
david55
Moves Like Spencer
 
Posts: 12570
Joined: Fri Sep 26, 2008 5:03 am

Re: Asterisk 13.6 Segfault No Core Dump

Postby neilsunerton » Tue Dec 22, 2015 8:01 am

Nope, it's running as root.
neilsunerton
Newsterisk
 
Posts: 6
Joined: Mon Oct 26, 2015 11:05 am


Return to Asterisk Support

Who is online

Users browsing this forum: Google [Bot] and 1 guest