Problem with websocket and sip messages

Get help with installing, upgrading and running Asterisk.

Moderators: muppetmaster, Moderator, Support

Problem with websocket and sip messages

Postby bof » Thu Dec 24, 2015 3:40 am

Hi,

Firstly Merry Christmas to all.

I have 2 standard udp SIP phone (A, B) with 2 webRTC SIP Phone (C and D).
When A and C are in communication there is not problem to send SIP (several SIP message) message from A to C. But where B and D are in communication to, many sip message are not send from Asterisk to D or from Asterisk to C.
The Sip messages arrive normaly from A and B to Asterisk but many are drop from Asterisk to C or to D.

Could you have any idea to understand and / or to solve this problem.

bof
bof
Newsterisk
 
Posts: 6
Joined: Thu Oct 16, 2014 3:24 am

Re: Problem with websocket and sip messages

Postby david55 » Thu Dec 24, 2015 3:51 am

Asterisk is a back to back user agent, not a proxy.

That means it terminates a SIP session on the incoming side and runs a completely different session, which might not even be SIP, on the outgoing side. No details of the SIP request contents are passed through the core of Asterisk.

There are certain circumstances in which it can take advantage of both sides being SIP and bypass the core, but those mainly relate to media handling.
david55
Moves Like Spencer
 
Posts: 12570
Joined: Fri Sep 26, 2008 5:03 am

Re: Problem with websocket and sip messages

Postby bof » Tue Dec 29, 2015 1:12 am

Hi,

I understand, but why all SIP messages are correctly send from A (udp SIP) to Asterisk and from Asterisk to C(websocket SIP) when they are alone. But when I add B(udp SIP) and D(websocket SIP) many SIP messages are drop between A and C and also between B and D.

bof
bof
Newsterisk
 
Posts: 6
Joined: Thu Oct 16, 2014 3:24 am

Re: Problem with websocket and sip messages

Postby david55 » Tue Dec 29, 2015 4:02 am

I'm assuming by message you mean request or response, not MESSAGE requests.

For the former, you should not be relying on requests and responses flowing end to end.

For the latter, you haven't provided enough information for me to understand your configuration and exactly what you are doing.
david55
Moves Like Spencer
 
Posts: 12570
Joined: Fri Sep 26, 2008 5:03 am


Return to Asterisk Support

Who is online

Users browsing this forum: Exabot [Bot], Google [Bot] and 1 guest