[SOLVED]LIBTONEZONE Error

Get help with installing, upgrading and running Asterisk.

Moderators: muppetmaster, Moderator, Support

[SOLVED]LIBTONEZONE Error

Postby alemono95 » Mon Dec 28, 2015 6:51 am

Hi to everyone.
I'm italian so my english is not so good...
This is my first topic
I've a problem with dahdi
I download and put it in /usr/src, i use the tar command to extract it, and then i use the "sudo make" command; and tha't the problem!!
The installation stops with this error:
"./.libs/libtonezone.so: undefined reference to `sin'
./.libs/libtonezone.so: undefined reference to `cos'
./.libs/libtonezone.so: undefined reference to `pow'
collect2: error: ld returned 1 exit status
"
I'm running ubuntu at the latest version and i'm using this guide: "http://wiki.openvox.cn/index.php?title=OpenVox_A400P_User_Manual_for_dahdi"
Help me please!!!

Ale
Last edited by alemono95 on Wed Dec 30, 2015 1:41 am, edited 1 time in total.
alemono95
Newsterisk
 
Posts: 9
Joined: Mon Dec 28, 2015 6:44 am

Re: LIBTONEZONE Error

Postby malcolmd » Mon Dec 28, 2015 9:19 am

Howdy,

You should probably take it up with OpenVox then. They sold you a product that they want you to use with DAHDI.
Malcolm Davenport
Digium, Inc. | Senior Product Manager
malcolmd
Moves Like Spencer
 
Posts: 3019
Joined: Wed Aug 03, 2005 3:53 pm
Location: Huntsville, AL, US

Re: LIBTONEZONE Error

Postby jaredfernandez » Mon Dec 28, 2015 2:27 pm

Hi alemono95,

This error has nothing at all to do with OpenVox. It appears to be a bug in the latest version of DAHDI (2.11.0) not correctly linking libraries in the make file. As a workaround, just use the previous version of DAHDI until this problem is corrected by the DAHDI maintainers. You can find 2.10.2 here: https://github.com/asterisk/dahdi-linux/archive/v2.10.2.tar.gz

Hope this helps!
Last edited by jaredfernandez on Tue Dec 29, 2015 11:26 am, edited 1 time in total.
jaredfernandez
Newsterisk
 
Posts: 1
Joined: Mon Dec 28, 2015 2:21 pm

Re: LIBTONEZONE Error

Postby alemono95 » Mon Dec 28, 2015 2:37 pm

malcolmd wrote:Howdy,

You should probably take it up with OpenVox then. They sold you a product that they want you to use with DAHDI.


Hi, thank you for The replay!!
I will write to Openvox, sure.
But ignoring The fact that i would like to install an Openvox, however i have a problem when i install dahdi
How can i fix that error during The installation?
Thanks!

Ale
alemono95
Newsterisk
 
Posts: 9
Joined: Mon Dec 28, 2015 6:44 am

Re: LIBTONEZONE Error

Postby abw1oim » Tue Dec 29, 2015 12:01 pm

I had the same proble using dahdi 2.11 under Ubuntu LTS 14.04.
Try to download dahdi 2.10 (if it's compatible with Your card). This should compile (in my case it did).
Hope this helps!
Olaf Winkler
Asterisk- & Database-Solutions
abw1oim
Oldsterisk
 
Posts: 358
Joined: Fri Aug 05, 2011 1:00 am
Location: Germany

Re: LIBTONEZONE Error

Postby alemono95 » Wed Dec 30, 2015 1:40 am

Thanks to Everyone!
I solved downloading an older version of Dahdi
Thanks!
Ale
alemono95
Newsterisk
 
Posts: 9
Joined: Mon Dec 28, 2015 6:44 am


Return to Asterisk Support

Who is online

Users browsing this forum: Google [Bot] and 1 guest