[RESOLVED] updating libsrtp

Get help with installing, upgrading and running Asterisk.

Moderators: muppetmaster, Moderator, Support

[RESOLVED] updating libsrtp

Postby meneses » Tue Jan 12, 2016 7:13 am

Hello there!

I'm using asterisk (11) with TLS and SRTP enabled and the extensions are working but I have a really old version of libsrtp (1.4) used when the system was installed.

Do I need to recompile asterisk if I update libsrtp?

Thanks!
Last edited by meneses on Tue Jan 12, 2016 11:34 am, edited 1 time in total.
meneses
Oldsterisk
 
Posts: 72
Joined: Fri Jul 25, 2008 7:26 am

Re: updating libsrtp

Postby malcolmd » Tue Jan 12, 2016 8:34 am

Yes, if you update libsrtp, you're going to want to rebuild Asterisk against the new libsrtp.

Libsrtp these days is hosted over at github. I recommend sticking with something in the 1.4 or 1.5 branches, as the 2.x stuff doesn't currently work (at least the last time I tried it).

Cheers
Malcolm Davenport
Digium, Inc. | Senior Product Manager
malcolmd
Moves Like Spencer
 
Posts: 3019
Joined: Wed Aug 03, 2005 3:53 pm
Location: Huntsville, AL, US

Re: [RESOLVED] updating libsrtp

Postby meneses » Tue Jan 12, 2016 11:34 am

It seemed terribly obvious, but I had to ask!

Thank you malcolmd.
meneses
Oldsterisk
 
Posts: 72
Joined: Fri Jul 25, 2008 7:26 am


Return to Asterisk Support

Who is online

Users browsing this forum: No registered users and 9 guests