Problem with Dahdi

Get help with installing, upgrading and running Asterisk.

Moderators: muppetmaster, Moderator, Support

Problem with Dahdi

Postby edestechnical » Wed Jan 27, 2016 7:10 am

Hi Asterisk folk,

I have an ubuntu server with asterisk packages from the repos and I have just added a wctdm24xxp card with FXS modules... now I have lots of this message coming up in the logs:

WARNING[2375] chan_dahdi.c: Read failed with -1: Invalid argument

This is accompanied by very high CPU and ram usage essentially bringing the server to a grinding halt...

I am using asterisk 11.7.0 on ubuntu 14.04.3

I am not sure what info to provide to help with this issue and googling the error gives no results that seem relevant to my issue. Any suggestions please?

Many thanks,
Ed
edestechnical
Newsterisk
 
Posts: 2
Joined: Fri Jan 15, 2016 4:48 am

Re: Problem with Dahdi

Postby penguinpbx » Mon Feb 01, 2016 6:40 pm

First, stop Asterisk from auto-starting, so you can examine the issue without locking up the box.

Then try to get DAHDI working before Asterisk. There are some binaries prefixed with dahdi_* that can help.

And you might want to double-check your configuration in /etc/dahdi/ directory.

Once DAHDI is up, then start Asterisk manually.
penguinpbx
Oldsterisk
 
Posts: 79
Joined: Mon Dec 10, 2007 9:31 am
Location: Denver, Colorado, USA


Return to Asterisk Support

Who is online

Users browsing this forum: No registered users and 18 guests