extensions unregistering after about 10 seconds

Get help with installing, upgrading and running Asterisk.

Moderators: muppetmaster, Moderator, Support

extensions unregistering after about 10 seconds

Postby pranahata » Tue Feb 02, 2016 7:02 am

Asterisk 13.6.0,

We have a number 4 chan_sip extensions.

0101 Xindows Xlite
0103 Zoiper for Android
0100 Cisco 7960 SIP phone
0300 Another SIP phone similar to the cisco one

if i run asterisk -vvvvvvvv

I see every 60 seconds the following:

-- Registered SIP '0100' at 180.216.8.79:1035

If I run sip show peers right after i see the above messages, i see

0100/0100 180.216.8.79 D No No A 1035 OK (248 ms)
0101/0101 180.216.8.79 D No No A 64429 OK (74 ms)
0103/0103 180.216.8.79 D Yes Yes A 64787 Unmonitored
0300/0300 (Unspecified) D Yes Yes A 0 Unmonitored

Then if I run it again, every second, i can see that after about 10 seconds the 0100 shows as (Unspecfied) and Port 0

-- Registered SIP '0300' at 141.136.148.156:5060
sip*CLI> sip show peers
Name/username Host Dyn Forcerport Comedia ACL Port Status Description
0100/0100 (Unspecified) D No No A 0 OK (248 ms)
0101/0101 180.216.8.79 D No No A 64429 OK (74 ms)
0103/0103 180.216.8.79 D Yes Yes A 64787 Unmonitored
0300/0300 141.136.148.156 D Yes Yes A 5060 Unmonitored
Telecube/1030679 103.193.167.41 Yes Yes 5060 Unmonitored

If i try to call the extensions while the Host is in unspecified status (about 40 seconds every minute) it doesn't connect, but if i call right after seing "-- Registered SIP '0100' at 180.216.8.79:1035" then it works.

I have tried setting qualify=no on the 0100 extension but the problem persist.

Any ideas as to why asterisk is unregistering these extensions and how to avoid it?

Thanks
pranahata
Newsterisk
 
Posts: 3
Joined: Sun Jul 26, 2015 5:24 am

Re: extensions unregistering after about 10 seconds

Postby ambiorixg12 » Tue Feb 02, 2016 10:21 am

There was a bug in 13.6 which could cause certain scheduled things to not work as expected, which is used for the qualify support. This was fixed in 13.7. I'd suggest you update to that before exploring further.

Joshua Colp


viewtopic.php?f=1&t=96620
ambiorixg12
Astmaster
 
Posts: 967
Joined: Sun Mar 04, 2007 9:32 pm
Location: Dominican Republic


Return to Asterisk Support

Who is online

Users browsing this forum: Google [Bot] and 12 guests