not able to register my ekiga softphone in asterisk...

General discussions about Asterisk.

Moderators: Moderator, Support

not able to register my ekiga softphone in asterisk...

Postby mia_tech » Tue Apr 15, 2008 12:35 am

I've just installed asterisk on ubuntu, and after configuring the sip.conf and the extensions.conf files, I setup ekiga to with the ip address of my asterisk pbx and is not registering... my asterisk is an internal ip address and here's the sip.conf file
Code: Select all
[general]
port = 5060
bindaddr = 0.0.0.0
context = others

[2000]
type=friend
context=my-phones
secret=1234
host=dynamic

[2001]
type=friend
context=my-phones
secret=1234
host=dynamic


and this is the extensions.conf
Code: Select all
[others]

[my-phones]
exten => 2000,1,Dial(SIP/2000)
exten => 2001,1,Dial(SIP/2001)


when connecting with ekiga I use:
username: 2000
password:1234
registrar: the ip address of my asterisk

any help appreciated

thanks
mia_tech
Newsterisk
 
Posts: 29
Joined: Mon Apr 14, 2008 10:44 am

Postby mia_tech » Tue Apr 15, 2008 1:08 am

well now when I run ekiga from the same box as my asterisk pbx I get this error

Code: Select all
-- Starting Skinny session from 127.0.0.1
[Apr 15 03:08:17] WARNING[22611]: chan_skinny.c:4387 get_input: read() returned error: Connection reset by peer
[Apr 15 03:08:17] NOTICE[22611]: chan_skinny.c:4484 skinny_session: Skinny Session returned: Connection reset by peer


hope that means something ...
mia_tech
Newsterisk
 
Posts: 29
Joined: Mon Apr 14, 2008 10:44 am

Postby mia_tech » Tue Apr 15, 2008 2:45 am

well I've tried two different softphones ( egika, and x-lite) none are connection or registering....I've noticed that my asterisk box is running on port 2000 is that the port in which the clients connect to asterisk?

thanks
mia_tech
Newsterisk
 
Posts: 29
Joined: Mon Apr 14, 2008 10:44 am

Postby mbruni » Tue Apr 15, 2008 3:06 am

No, the sip signalling port is udp 5060, use the * cli command "sip set debug" to check if the phones are sending the sip messages to register themself.

Cheers.

Marco Bruni
mbruni
Astmaster
 
Posts: 957
Joined: Thu Dec 21, 2006 10:56 pm
Location: Arezzo, Italy

Postby mia_tech » Tue Apr 15, 2008 9:33 am

how can I change the port on which asterisk listen for connection....
mia_tech
Newsterisk
 
Posts: 29
Joined: Mon Apr 14, 2008 10:44 am

Postby mbruni » Tue Apr 15, 2008 10:00 am

In sip.conf, section "general", check the value of the parameter "bindport".

Cheers.

Marco Bruni
mbruni
Astmaster
 
Posts: 957
Joined: Thu Dec 21, 2006 10:56 pm
Location: Arezzo, Italy

Postby mia_tech » Tue Apr 15, 2008 10:31 am

yes the bindport is set to 5060, but I ran nmap against the local machine and no udp port is listening on 5060 here's the output
Code: Select all
jorge@ubuntu-box:~$ sudo nmap -sU -p 5000-5100 localhost

Starting Nmap 4.53 ( http://insecure.org ) at 2008-04-15 12:28 EDT
All 101 scanned ports on localhost (127.0.0.1) are closed

Nmap done: 1 IP address (1 host up) scanned in 0.123 seconds


any help appreciated

thanks
[/code]
mia_tech
Newsterisk
 
Posts: 29
Joined: Mon Apr 14, 2008 10:44 am

Postby mia_tech » Tue Apr 15, 2008 12:18 pm

well I finally got asterisk to listen on port 5060:
Code: Select all
jorge@ubuntu-box:~$ sudo nmap -sU -p 5000-5100 localhost
[sudo] password for jorge:

Starting Nmap 4.53 ( http://insecure.org ) at 2008-04-15 14:14 EDT
Interesting ports on localhost (127.0.0.1):
Not shown: 100 closed ports
PORT     STATE         SERVICE
5060/udp open|filtered sip

and the reason been is that I think it was b/c I had a softphone installed on the same box, and probably the ports were conflicting.. "I think", after I uninstalled ekiga, and restarted asterisk all my softphone from other pc were able to connect I could be wrong.. please correct me if that's the case.
I would like to have some sort of softphone installed on the same machine as my asterisk box... .how could I change the port on which the softphone like ekiga or other is listening for connection?

thanks
http://www.pcteckonline.org
mia_tech
Newsterisk
 
Posts: 29
Joined: Mon Apr 14, 2008 10:44 am

Postby mbruni » Wed Apr 16, 2008 1:50 am

You're right, the 5060 udp port is the default for Ekiga too and there is a conflict with Asterisk, so one of them has to use a different port when on the same box.
I checked the Ekiga installed on my box and seems there is no way to change the sip listening port.

Cheers.

Marco Bruni
mbruni
Astmaster
 
Posts: 957
Joined: Thu Dec 21, 2006 10:56 pm
Location: Arezzo, Italy

Postby sefs » Sat Dec 13, 2008 7:23 pm

On linux port can be changed by launching the gconf-editor and going to
apps->ekiga->protocols->sip and change the listenport value from 5060 to whatever you want.
sefs
Newsterisk
 
Posts: 20
Joined: Tue Nov 11, 2008 12:00 am


Return to Asterisk General

Who is online

Users browsing this forum: No registered users and 7 guests