ELI5 - What does this mean? From Debug log.

General discussions about Asterisk.

Moderators: Moderator, Support

ELI5 - What does this mean? From Debug log.

Postby canwan » Sat Nov 07, 2015 2:51 pm

I am having trouble with my Asterisk 11.2.1 box. When the problem arrises I am seeing the same 3 things flooding the logs, thousands of times per second. Can someone please explain to me what is causing this message and what it means? Thanks In advance.

[Nov 7 08:50:29] DEBUG[26622][C-000003d6] res_rtp_asterisk.c: 0x7f3c780ae3e0 -- Condition for learning hasn't exited, so reject the frame.
[Nov 7 08:50:29] DEBUG[26622][C-000003d6] res_rtp_asterisk.c: 0x7f3c780ae3e0 -- start learning mode pass with addr = xxxxxxxxxxxx:15760
[Nov 7 08:50:29] DEBUG[26622][C-000003d6] res_rtp_asterisk.c: 0x7f3c780ae3e0 -- probation = 2, seq = 27423
canwan
Newsterisk
 
Posts: 8
Joined: Tue Sep 15, 2015 7:38 pm

Re: ELI5 - What does this mean? From Debug log.

Postby david55 » Sun Nov 08, 2015 2:08 am

Having debugging enabled is what is causing the messages. You should always describe the fault symptom properly when providing debugging messages,as debug messages generally describe non-fault conditions.

These all seem to relate to the following rtp.conf options:

Code: Select all
; Enable strict RTP protection. This will drop RTP packets that
; do not come from the source of the RTP stream. This option is
; enabled by default.
; strictrtp=yes
;
; Number of packets containing consecutive sequence values needed
; to change the RTP source socket address. This option only comes
; into play while using strictrtp=yes. Consider changing this value
; if rtp packets are dropped from one or both ends after a call is
; connected. This option is set to 4 by default.
; probation=8


Please note that the General forums are for making comments, not for asking questions.
david55
Moves Like Spencer
 
Posts: 12570
Joined: Fri Sep 26, 2008 5:03 am

Re: ELI5 - What does this mean? From Debug log.

Postby canwan » Sun Nov 08, 2015 8:27 am

Thanks for the reply david.

I tried my best to explain the problem here:
viewtopic.php?f=1&t=95779

But after a few months of no replies, and the condition worsening, I tried to figure out the problem myself.

Last night I updated to the 11.20.0 (from 11.2.1) as I found some issues in the upgrade log that may be related. I also identified some possible other causes with some cron jobs doing file backups that could possibly be causing it. Hopefully these issue will resolve it, if not I will try to explain things better and go from there.

Thanks for the tip.
canwan
Newsterisk
 
Posts: 8
Joined: Tue Sep 15, 2015 7:38 pm


Return to Asterisk General

Who is online

Users browsing this forum: Google [Bot] and 1 guest