Install goes great, reboot fails..?

Get help with installing and running AsteriskNOW.

Moderators: Moderator, Support

Install goes great, reboot fails..?

Postby web-keeper-666 » Wed Dec 27, 2006 6:22 pm

Hi I have to say I am greatful that someone decided to keep compatability to a max...

I have a NetServer LH4 and have finally found a flavour of Asterisk that I can install without the horrible kernel dumps CentOS gives me, (CentOS actually crashes at the vmlinux install level), they say is got something to do with the new version of uDev, I dont know..!.

In saying this I seem to have a small problem..? The install goes great, it finds the "megaraid" controller and completes the install just fine.

At the last screen where it states "please remove any media....." and REBOOT, I remove the CD, and hit enter to reboot. The LH4 reboots and completes the post operations, and the cursur starts blinking in the top left corner as if it is about to start linux... but thats as far as it gets, its almost like it is having a hard time finding the OS. It seems to act like there is an OS but it just can't find it.

I thought I did something wrong so I inserted the CD and started again, making sure I chose "Remove all Partitions" this time. Something all went well, install completed, I reboot, then nothing, flashing cursur in the top left corner of the screen.

System Specs:
x4 P3 550/1mb cache
x4Gb Ram
x5 18Gb SCSI's in Hardware Raid 5
Standard NetRaid on-board controller (uses megaraid driver)

I realy would like to get this machine running with Asterisk as I have a old PC kurrently struggling to use Trixbox.

You prompt assistance in this issue is greatly appreciated.

Thanks Jon. :?
web-keeper-666
Newsterisk
 
Posts: 6
Joined: Tue Nov 28, 2006 12:02 am

Postby bkruse » Thu Jan 04, 2007 3:14 pm

hey john, it sounds like grub did not install to the MBR or something similar probably due to the vmlinuz image not having the correct modules to fully operate your raid controller ( happend to me unfortunatly, with all these new controllers coming out )

I would suggest ( if you are fimiliar with linux ) trying to boot from a live cd and chroot into the mounted partition, or before that, see if anything did, in fact, install.

It sounds like a boot partition problem to me though, I would suggest trying to reinstall and make sure to chose "install to MBR" or something similar.


Hopes this help!

-bkruse
bkruse
Site Admin
 
Posts: 878
Joined: Mon Dec 04, 2006 3:20 pm
Location: Huntsville, Alabama

Install goes great, reboot fails..?

Postby web-keeper-666 » Thu Jan 04, 2007 7:26 pm

Thanks bkruse,
you are correct, it was a boot loader issue and I have since repaired this problem and the test machine is working well.

I have found though while rPATH Linux and AsteriskNOW is a good combination for most, unfortunately, I find myself in another difficult situation as I need to also install some other software on this machine and can't seem to master "conary", so I have reverted back to FC6.

I am going to attempt to follow the instructions on asterisk-guru, and see if this suits my asterisk server requirements better. This way I know I will have no problems with the other required software we need to run.

Once again thanks.

Regards,
Jon
web-keeper-666
Newsterisk
 
Posts: 6
Joined: Tue Nov 28, 2006 12:02 am

Postby bkruse » Thu Jan 04, 2007 10:21 pm

Ha, conary is still developing.

Its great once you get to learn it, but the learning curve is a little higher then those of conventional package management.

We might end up having some more documentation on everything about conary and asterisk, in a very readable form.

Just give it some time :]
bkruse
Site Admin
 
Posts: 878
Joined: Mon Dec 04, 2006 3:20 pm
Location: Huntsville, Alabama

Install goes great, reboot fails..?

Postby web-keeper-666 » Thu Jan 04, 2007 10:33 pm

Thanks for that bkruse.
I look forward to watching its progress.

Unfortunately I have to say that because my need is now,
I will attempt Fedora Core 6 (only because I know it installs nicely),
and try the install of Asterisk as documented at Asterisk-GURU.

If you have any suggestion on this combination, (fc6 + asterisk),
I welcome them..!

Thanks again.
Jon
web-keeper-666
Newsterisk
 
Posts: 6
Joined: Tue Nov 28, 2006 12:02 am

Postby bkruse » Fri Jan 05, 2007 2:17 pm

Keep an eye on it.

and look on http://voip-info.org for quick solutions.

Good luck man!

glad i could help, do what gets the job done.

-bkruse
bkruse
Site Admin
 
Posts: 878
Joined: Mon Dec 04, 2006 3:20 pm
Location: Huntsville, Alabama


Return to AsteriskNOW Support

Who is online

Users browsing this forum: Exabot [Bot] and 1 guest