AsteriskNOW 1.4.0 b2 GUI password problem

Get help with installing and running AsteriskNOW.

Moderators: Moderator, Support

AsteriskNOW 1.4.0 b2 GUI password problem

Postby timingalls » Wed Jan 10, 2007 9:49 am

I just installed AsteriskNOW from asterisk-1.4.0-beta2-x86-disc1.iso from an ISO I just downloaded today. I then connected to the Web GUI as instructed. It asks for my username and password, which is the password set during install. After entering "admin" and the password, it says "CONNECTED!" and then gives me over to another login page for the setup wizard. When I put in the same username and password, the page just reloads and asks again for my username and password. No number of times repeating said ritual will get me to the next page.

I'm using Firefox 2. I checked /etc/asterisk/manager.conf and it has the correct admin password. I tried using "admin" and "password" for the password, but that didn't help. I think there is something wrong with one of the JavaScript files on the /static/config/setup/index.html page (prototype.js or astman.js) because the index.html has next to nothing in it.

I've installed it twice: once using the Expert method; and once using the Custom method. When I did the Custom method, the only things I changed were to rename the host name and add a boot loader password. All other opitons were the default options. I'm about to install it again using the Express install method, but I don't think I'll see any difference.

I asked the question on the #asteriskNOW IRC channel, but I thought I'd try here now so the answers would end up being posted publicly. Does anyone else run into the same issues?
Posts: 5
Joined: Mon Jan 08, 2007 6:31 pm

Postby j4m3s » Wed Jan 10, 2007 12:13 pm

This sounds like a problem with Firefox2. Can you try downloading and seeing if you have the same problem?
Posts: 249
Joined: Fri Dec 22, 2006 1:31 pm

Postby olsjohnluke » Wed Jan 10, 2007 3:17 pm

I had something of the same issue. Did firefox give you any certificate info? Such as: The web site you are going to is blah.mydomain.local but the certificate identified itself as (substituting details of course)? If so, did you permantently accept it, temporarily accept it? I found myself in that problem with Firefox, then used Opera 10 which fixed it, then Opera had the same problem, but now Firefox works - only relation I found was the way each browser handled the misidentified certificate. May be a tie-in with ?
Posts: 28
Joined: Fri Dec 01, 2006 3:36 pm

AsteriskNOW 1.4.0 b2 GUI password problem

Postby timingalls » Wed Jan 10, 2007 5:48 pm

I tried Netscape Browser ver. 8.1 which is based on the 1.5 version of Firefox, and the problem went away. As for the certificate issue noted by olsjohnluke, I did get a warning for the certificate, but I don't remember what it said. I assumed that it was warning that the certificate was self-signed.

It would be nice to figure out why I can't use Firefox 2 with the GUI.
Posts: 5
Joined: Mon Jan 08, 2007 6:31 pm

Postby bkruse » Wed Jan 10, 2007 11:28 pm


ya, your right, most def.

This will get fixed, we are working on core features and we are working on functionality first.

Then I imagine they will go for the newer, older, and different browsers of course.
Site Admin
Posts: 878
Joined: Mon Dec 04, 2006 3:20 pm
Location: Huntsville, Alabama

Postby timingalls » Thu Jan 11, 2007 12:21 am

Thanks a bunch for the help! :)
Posts: 5
Joined: Mon Jan 08, 2007 6:31 pm

same problem here but how i fixed it

Postby ryry46d9 » Thu Jan 11, 2007 1:30 am

I did the F9 trick "!" to get to the root prompt passwd'ed it and reloaded asterisk to find the same problem but IE7 loaded it so thats where i thought i should restart Firefox and it works again

Now to find out why i cant here any audio through SJ phone calling 8500

hope this helps people

ryan dolstad
Posts: 5
Joined: Sun Dec 31, 2006 2:32 am

Postby transcendent » Tue Jan 23, 2007 3:11 pm

I had the same problem with Firefox 2 and 1.5 on new install AsteriskNOW 1.4.0 Beta 2 at /cfgbasic.html and /cfgadvanced.html login screens.

Cleared history, cache and cookies on both browsers and now able to use Firefox 1.5 and 2
Posts: 9
Joined: Thu Nov 23, 2006 5:40 am

Return to AsteriskNOW Support

Who is online

Users browsing this forum: No registered users and 1 guest