Upgrading LibSS7 to 2.0.0

Get help with installing and running AsteriskNOW.

Moderators: Moderator, Support

Upgrading LibSS7 to 2.0.0

Postby farzan » Sat Sep 06, 2014 9:23 am

Hi all,

I am facing a problem with libss7 that do not support RDNIS, however according to (https://issues.asterisk.org/jira/browse/SS7-48) it is fixed in libss7 v 2.0. Now I want to upgrade my current installation. I've downloaded latest dahdi-linux-complete from asterisk.org and also latest libss7 sources. I just did make; make install on both of them and also restarted amportal but still issuing ss7 show version on asterisk CLI shows version: 1.0.2.
I have checked libss7.so located in /usr/lib and I made sure that it is linked to /usr/lib/libss7.so.2.0 which appears fine to me.

Any idea on what am I missing?

Best Regards
farzan
Newsterisk
 
Posts: 21
Joined: Sat Sep 06, 2014 8:07 am

Re: Upgrading LibSS7 to 2.0.0

Postby farzan » Sat Sep 06, 2014 5:57 pm

I found the problem, and fixed it.

I was running Asterisk 11.11.0 but for libss7 2.0 I had to upgrade to Asterisk 13. I followed the instructions on this link https://wiki.asterisk.org/wiki/display/AST/Installing+Asterisk+From+Source to do so. And for those who might be interested, I confirm that the problem with RDNIS is fixed in libss7 2.0.
farzan
Newsterisk
 
Posts: 21
Joined: Sat Sep 06, 2014 8:07 am

Re: Upgrading LibSS7 to 2.0.0

Postby sadaf123 » Tue Dec 16, 2014 5:46 am

Dear Farzan,
I need to confirm one thing whether libss7 worked with asterisk 13? If you are using it than which version of libss7 you are using with asterisk 13?

Thanks.
sadaf123
Newsterisk
 
Posts: 1
Joined: Tue Dec 16, 2014 5:44 am


Return to AsteriskNOW Support

Who is online

Users browsing this forum: Exabot [Bot] and 1 guest