AsteriskNOW yum update dependency issues with libresample

Get help with installing and running AsteriskNOW.

Moderators: Moderator, Support

AsteriskNOW yum update dependency issues with libresample

Postby rkrenzis » Tue Apr 21, 2015 12:01 am

When executing 'yum update' from the command line, the EPEL repo is pulling in an update libresample and of course the asterisk11-core package has a dependency on this library.

Code: Select all
Error: Package: asterisk11-core-11.14.2-1.shmz65.1.41.x86_64 (@pbx)
           Requires: libresample.so.1.0()(64bit)
           Removing: libresample-0.1.3-11_centos6.x86_64 (@anaconda-PBX-201403180405.x86_64/6.5)
               libresample.so.1.0()(64bit)
           Updated By: libresample-0.1.3-12.el6.x86_64 (epel)
               Not found


Should not libresample be set as a dependency from @pbx repository and ignore updates from EPEL? Or perhaps this is a problem that has not yet been reported?

Complete output 'yum update' after running a 'yum clean all'

Code: Select all
Loaded plugins: fastestmirror, kmod
Determining fastest mirrors
epel/metalink                                                                                                                                          |  14 kB     00:00     
* epel: mirror.cogentco.com
base                                                                                                                                                   | 2.0 kB     00:00     
base/primary                                                                                                                                           | 2.5 MB     00:01     
base                                                                                                                                                                6402/6402
epel                                                                                                                                                   | 4.4 kB     00:00     
epel/primary_db                                                                                                                                        | 6.5 MB     00:03     
extras                                                                                                                                                 | 1.3 kB     00:00     
extras/primary                                                                                                                                         | 6.8 kB     00:00     
extras                                                                                                                                                                  15/15
pbx                                                                                                                                                    | 1.3 kB     00:00     
pbx/primary                                                                                                                                            | 407 kB     00:00     
pbx                                                                                                                                                                 1647/1647
schmooze-commercial                                                                                                                                    | 1.3 kB     00:00     
schmooze-commercial/primary                                                                                                                            |  22 kB     00:00     
schmooze-commercial                                                                                                                                                   150/150
updates                                                                                                                                                | 1.3 kB     00:00     
updates/primary                                                                                                                                        | 644 kB     00:00     
updates                                                                                                                                                             1456/1456
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package apcupsd.x86_64 0:3.14.10-1.el6.rf will be updated
---> Package apcupsd.x86_64 0:3.14.12-1.el6 will be an update
--> Processing Dependency: libnetsnmp.so.20()(64bit) for package: apcupsd-3.14.12-1.el6.x86_64
---> Package fail2ban.noarch 0:0.8.8-108.shmz65.1.121 will be updated
---> Package fail2ban.noarch 0:0.8.14-1.el6 will be an update
--> Processing Dependency: python-inotify for package: fail2ban-0.8.14-1.el6.noarch
--> Processing Dependency: ed for package: fail2ban-0.8.14-1.el6.noarch
---> Package jack-audio-connection-kit.x86_64 0:0.116.1-6_1.el6 will be updated
---> Package jack-audio-connection-kit.x86_64 0:0.121.3-1.el6 will be an update
---> Package libpri.x86_64 0:1.4.12-13.shmz65.1.4 will be updated
---> Package libpri.x86_64 0:1.4.13-1.el6 will be an update
---> Package libpri-devel.x86_64 0:1.4.12-13.shmz65.1.4 will be updated
---> Package libpri-devel.x86_64 0:1.4.13-1.el6 will be an update
---> Package libresample.x86_64 0:0.1.3-11_centos6 will be updated
--> Processing Dependency: libresample.so.1.0()(64bit) for package: asterisk11-core-11.14.2-1.shmz65.1.41.x86_64
---> Package libresample.x86_64 0:0.1.3-12.el6 will be an update
---> Package libsrtp.x86_64 0:1.4.4-4.20101004cvs.el6 will be updated
---> Package libsrtp.x86_64 0:1.4.4-10.20101004cvs.el6 will be an update
---> Package libsrtp-devel.x86_64 0:1.4.4-4.20101004cvs.el6 will be updated
---> Package libsrtp-devel.x86_64 0:1.4.4-10.20101004cvs.el6 will be an update
---> Package lua-dbi.x86_64 0:0.5-2.el6 will be updated
---> Package lua-dbi.x86_64 0:0.5-5.el6 will be an update
---> Package lua-expat.x86_64 0:1.2.0-1.el6 will be updated
---> Package lua-expat.x86_64 0:1.3.0-1.el6 will be an update
---> Package mosh.x86_64 0:1.2-2.el6 will be updated
---> Package mosh.x86_64 0:1.2.4-1.el6 will be an update
---> Package openvpn.x86_64 0:2.0.9-1.el6.rf will be updated
---> Package openvpn.x86_64 0:2.3.6-1.el6 will be an update
--> Processing Dependency: libpkcs11-helper.so.1()(64bit) for package: openvpn-2.3.6-1.el6.x86_64
---> Package portaudio.x86_64 0:19-6_4_20071207.el6 will be updated
---> Package portaudio.x86_64 0:19-9.el6 will be an update
---> Package prosody.x86_64 0:0.9.1-102.shmz65.1.15 will be updated
---> Package prosody.x86_64 0:0.9.8-1.el6 will be an update
---> Package protobuf.x86_64 0:2.3.0-7.el6 will be updated
---> Package protobuf.x86_64 0:2.3.0-9.el6 will be an update
---> Package sqlite2.x86_64 0:2.8.17-8.el6 will be updated
---> Package sqlite2.x86_64 0:2.8.17-10.el6 will be an update
--> Running transaction check
---> Package ed.x86_64 0:1.1-3.3.el6 will be installed
---> Package libresample.x86_64 0:0.1.3-11_centos6 will be updated
--> Processing Dependency: libresample.so.1.0()(64bit) for package: asterisk11-core-11.14.2-1.shmz65.1.41.x86_64
---> Package net-snmp-libs.x86_64 1:5.5-49.el6_5.4 will be installed
---> Package pkcs11-helper.x86_64 0:1.11-3.el6 will be installed
---> Package python-inotify.noarch 0:0.9.1-1.el6 will be installed
--> Finished Dependency Resolution
Error: Package: asterisk11-core-11.14.2-1.shmz65.1.41.x86_64 (@pbx)
           Requires: libresample.so.1.0()(64bit)
           Removing: libresample-0.1.3-11_centos6.x86_64 (@anaconda-PBX-201403180405.x86_64/6.5)
               libresample.so.1.0()(64bit)
           Updated By: libresample-0.1.3-12.el6.x86_64 (epel)
               Not found
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest


I have looked at the dependency list for libresample and it would probably be safe to execute 'yum --skip-broken update' without implications.

Code: Select all
# repoquery --requires --recursive --resolve libresample
libresample-0:0.1.3-12.el6.i686
libresample-0:0.1.3-12.el6.x86_64
glibc-0:2.12-1.132.el6.i686
libsndfile-0:1.0.20-5.el6.i686
libsndfile-0:1.0.20-5.el6.x86_64
glibc-0:2.12-1.132.el6_5.2.x86_64


I'm not exactly sure which distribution of AsteriskNOW I am running. Output from redhat-release:
Code: Select all
# cat redhat-release
SHMZ release 6.5 (Final)


Thoughts?
rkrenzis
Newsterisk
 
Posts: 2
Joined: Mon Apr 20, 2015 11:47 pm

Re: AsteriskNOW yum update dependency issues with libresample

Postby david55 » Tue Apr 21, 2015 12:50 am

I'm not aware of any way of specifying constraints which aren't in the RPM, and RPMs know nothing about yum repositories.

If there is backwards compatibility violation, this would have to be handled by an upper limit on the version number, but you don't know when the breach will happen, and restricting to a single version number is normally too restrictive.
david55
Moves Like Spencer
 
Posts: 12570
Joined: Fri Sep 26, 2008 5:03 am

[RESOLVED] AsteriskNOW yum update dep issues w/libresample

Postby rkrenzis » Sun Jul 26, 2015 4:08 pm

I was able to resolve my issues by using the update scripts located here:
http://wiki.freepbx.org/display/FD/Upda ... ial+Distro
rkrenzis
Newsterisk
 
Posts: 2
Joined: Mon Apr 20, 2015 11:47 pm


Return to AsteriskNOW Support

Who is online

Users browsing this forum: No registered users and 1 guest