SOLVED: no inbound calls on sip trunk

Get help with installing and running AsteriskNOW.

Moderators: Moderator, Support

SOLVED: no inbound calls on sip trunk

Postby tonj » Thu Jun 25, 2015 1:13 pm

I'm running AsteriskNOW-612-current-64 and I can't get incoming calls to work on the sip trunk. Outgoing calls work fine but they only have one-way audio. In the past I used the asterisk-gui (now discontinued) so I'm new to freepbx. I've been reading the wiki, trawling google for hours trying so many different configs but nothing works.
I have a sip account with draytel.org and I think the problem is finding the correct settings to go in the 'incoming settings' of the sip trunk page, I can't find the correct settings. The trunk is up and registered, the extension is working fine, I did a debug trace on an incoming call and I can see the activity, everything looks fine but the extension will not ring and the call goes to (draytels own) voicemail.

[code]outgoing settings
username=<my-username>
fromuser=<my-username>
secret=<my-secret>
host=draytel.org
fromdomain=draytel.org
type=friend
context=from-trunk
insecure=port,invite
trustrpid=yes
sendrpid=yes
directmedia=no
qualify=yes
keepalive=45
nat=yes
dtmfmode=rfc2833
disallow=all
allow=ulaw
[/code]

[code]incoming settings
type=friend
fromdomain=draytel.org
host=draytel.org
insecure=invite,port
context=from-trunk
port=5061
canreinvite=no[/code]

I've also checked that my inbound route settings are correct too.

thanks for any help, this is driving me batty.
ps: I don't know why the code tags aren't working.

update: I got it working, the problem was I had the asterisk machine connected to the internet vias a vpn tunnel. I'm not sure why but asterisk doesn't like being in a tunnel.
tonj
Oldsterisk
 
Posts: 62
Joined: Tue Sep 06, 2011 3:55 am

Return to AsteriskNOW Support

Who is online

Users browsing this forum: No registered users and 1 guest