Page 1 of 1

FFA problems

PostPosted: Mon May 11, 2009 2:37 am
by stich86
Hi guys,

i've got FFA installed on asterisk 1.6.0.9 to testing T.38 fax. The voip provider is Eutelia in Italy (that support T.38 codecs).

When I send a fax from an analog fax machine to voip number, i get ring tones and not fax tones, and fax doesn't arrive :( (INBOUND route with 5s of wainting time)

When I send a fax from a WEB2FAX services, first call arrive in G711, then it switch to T38 codec and after 10secs i get error "T1_TIMEOUT"..

Where is the problem? And why i cannot send fax via a regular fax machine?
Can only send VoIP-to-VoIP and not PSTN-to-VoIP?

Thanks!

PostPosted: Fri May 22, 2009 12:11 pm
by sethsdad0627
do you have faxdetect uncommented in dahdi.conf?

PostPosted: Wed Jun 03, 2009 6:42 am
by nmazzon
why do we have to use chan_dahdi.conf if we have a sip trunk?

PostPosted: Wed Jun 03, 2009 7:08 am
by sethsdad0627
You don't. I missed that part. Have you tried putting a Wait in your dialplan ahead of ReceiveFax to allow for negotiations to settle? Apparently in a V-V connection this isn't an issue, but throwing PSTN into the loop will introduce a 3-10 second delay.

PostPosted: Wed Jun 03, 2009 8:32 am
by nmazzon
ok, thanks.

But my problem is with V-V comunication

my system is this

FAX Machine <--> ATA <--> Asterisk

Is it a correct structure?

In a second step it'll be similar to

PSTN <--> ATA <--> Asterisk

I can't receive fax, error is this

Code: Select all
   -- Channel 'SIP/1101-083a0378' receiving fax '/home/tvox/fax_files/fax-2-rx.tif'
    -- Channel 'SIP/1101-083a0378' fax session '1', [ 000.003692 ], STAT_EVT_STRT_RX       st: IDLE         rt: IDLENSRX
    -- Channel 'SIP/1101-083a0378' fax session '1', [ 000.004333 ], STAT_EVT_RX_HW_RDY     st: WT_RX_HW_RDY rt: RRDYNHRY
    -- Channel 'SIP/1101-083a0378' fax session '1', [ 000.004717 ], STAT_INFO_CSI
    -- Channel 'SIP/1101-083a0378' fax session '1', [ 000.005084 ], STAT_INFO_DIS
    -- Channel 'SIP/1101-083a0378' fax session '1' started
    -- Channel 'SIP/1101-083a0378' fax session '1', [ 000.005829 ],  >>>>>> (to stack)  completed sending '   0' frames (     0 ms) of 'energy ', now sending 'energy '.
    -- Channel 'SIP/1101-083a0378' fax session '1', [ 000.006247 ],  <<<<<< (to chan)   completed sending '   0' frames (     0 ms) of 'energy ', now sending 'energy '.
    -- Channel 'SIP/1101-083a0378' fax session '1', [ 000.145118 ], STAT_EVT_TMR_INT_EXP   st: WT_DIS_RSP   rt: XXXXNTIX
    -- Channel 'SIP/1101-083a0378' switched to T.38 fax session '2'.

PostPosted: Wed Jun 03, 2009 8:35 am
by sethsdad0627
try it again making sure debug and ecm are on(yes).

PostPosted: Wed Jun 03, 2009 9:23 am
by nmazzon
I set debug on cli ( verbose and debug ) and test ecm=yes.
Results didn't change..

PostPosted: Wed Jun 03, 2009 9:26 am
by sethsdad0627
Read these links and see if they are of any help
http://en.wikipedia.org/wiki/T.38
http://www.voip-info.org/wiki/view/T.38

PostPosted: Wed Jun 03, 2009 9:31 am
by nmazzon
Thank you very much for your support i have just read this document and i didn't find any answer to my problem.

Digium's manual is better but thank you again.

PostPosted: Wed Jun 03, 2009 9:34 am
by sethsdad0627
Have you opened a ticket with Digium? FFA is supposed to support T.38.

Re: FFA problems

PostPosted: Wed Jun 03, 2009 12:25 pm
by VMikhelson
stich86 wrote:Hi guys,

i've got FFA installed on asterisk 1.6.0.9 to testing T.38 fax. The voip provider is Eutelia in Italy (that support T.38 codecs).

When I send a fax from an analog fax machine to voip number, i get ring tones and not fax tones, and fax doesn't arrive :( (INBOUND route with 5s of wainting time)

When I send a fax from a WEB2FAX services, first call arrive in G711, then it switch to T38 codec and after 10secs i get error "T1_TIMEOUT"..

Where is the problem? And why i cannot send fax via a regular fax machine?
Can only send VoIP-to-VoIP and not PSTN-to-VoIP?

Thanks!


Just my 2 cents.

It seems to be a problem with ReceiveFAX application. It does not send back tones and negotiation never happens. End result -- timeout. I tested on DAHDI - very similar result.

Should it be submitted as a bug report to Digium? Or do they monitor these forums? Just talking to myself....

-Vladimir

PostPosted: Wed Jun 03, 2009 12:28 pm
by sethsdad0627
These forums are moderated but not monitored in a strict sense. The idea (IMHO) is to try to solve the "goofy" stuff here and when you don't get an answer, escalate your problem to a format Asterisk issue for "real" support.

PostPosted: Thu Jun 04, 2009 2:31 am
by nmazzon
about my problem I opened a issue at Digium.

I listened tone calling the number from a sip phone.

My call is cancelled and then closed for timeout.

I can't understand the fax debug messagges.. so I hope Digium help me.. :roll:

PostPosted: Mon Jun 29, 2009 11:07 pm
by VMikhelson
Any progress with the Digium support ticket?

-Vladimir

PostPosted: Tue Jun 30, 2009 1:00 am
by nmazzon
They asked me many log file but at this moment I have not got any solutions.

I am waiting.. :roll:
and trying other solution.. with no good results.. :cry: :cry:

PostPosted: Tue Jun 30, 2009 9:50 am
by VMikhelson
nmazzon wrote:They asked me many log file but at this moment I have not got any solutions.

I am waiting.. :roll:
and trying other solution.. with no good results.. :cry: :cry:


Can you please post a link to the Digium issue here.

Thank you,
Vladimir

PostPosted: Fri Jul 03, 2009 1:40 am
by nmazzon
I opened a support case to Digium after bought a Fax For Asterisk license,

I am waiting news from them..