can't load the modules

Community-based Support for users of Free Fax For Asterisk

can't load the modules

Postby dponzone » Fri May 22, 2009 7:56 am

I wanted to give a try to FFA but I can't find a way to load the modules:

root@ns354349:~# asterisk -V
Asterisk 1.4.23-rc1

ns354349*CLI> module load res_fax.so
[May 22 15:44:07] WARNING[18764]: loader.c:359 load_dynamic_module: Error loading module 'res_fax.so': /usr/local/lib/asterisk/modules/res_fax.so: cannot open shared object file: No such file or directory
[May 22 15:44:07] WARNING[18764]: loader.c:653 load_resource: Module 'res_fax.so' could not be loaded.

but the files are there:

root@ns354349:/usr/local/lib/asterisk/modules# ls -l res_fax*
-rwxr-xr-x 1 root staff 1374804 2009-05-22 14:52 res_fax_digium.so
-rwxr-xr-x 1 root staff 49180 2009-05-22 14:51 res_fax.so

root@ns354349:/usr/local/lib/asterisk/modules# file res_fax*
res_fax_digium.so: ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), stripped
res_fax.so: ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), stripped

(For info, I look the c3-2 version, following the benchfax result, despite the fact that the CPU is a Core2Duo).

root@ns354349:/usr/local/lib/asterisk/modules# uname -a
Linux ns354349.ovh.net 2.6.24.5-xxxx-std-ipv4-64 #1 SMP Thu Nov 27 17:08:30 CET 2008 x86_64 GNU/Linux

I am stuck there.

Any ideas ?

Thanks
dponzone
Newsterisk
 
Posts: 9
Joined: Thu Dec 21, 2006 10:56 pm
Location: Paris, France

Postby sethsdad0627 » Fri May 22, 2009 11:50 am

You're probably running Asterisk as a non-root user. You can try chmod 0777 on the files and see if they load then.
sethsdad0627
Oldsterisk
 
Posts: 208
Joined: Tue Nov 04, 2008 9:15 am

Postby dponzone » Fri May 22, 2009 4:37 pm

Nope, my Asterisk is running as root, and all my modules are 755.
Nice try anyway, I forgot to check that!

I am really getting crazy on this...
dponzone
Newsterisk
 
Posts: 9
Joined: Thu Dec 21, 2006 10:56 pm
Location: Paris, France

How to load the module

Postby tiloulou » Mon May 25, 2009 8:09 pm

You have to disable SELINUX in the directory /etc/selinux and in config put : selinux=disabled.

Good Luck

Tiloulou
tiloulou
Newsterisk
 
Posts: 10
Joined: Wed Nov 21, 2007 6:35 pm

Postby dponzone » Tue May 26, 2009 3:31 am

My sillyness!
I was absolutely not aware SELINUX was enabled on my Debian.

Thanks, I am rebooting now, and pretty sure it gonna work!
dponzone
Newsterisk
 
Posts: 9
Joined: Thu Dec 21, 2006 10:56 pm
Location: Paris, France

Postby dponzone » Tue May 26, 2009 3:54 am

I replied too quickly...

Even after disabling SELINUX and rebooted, I can't load the FFA modules.
Anyway, SELINUX was in permissive mode before, so I guess it was not hurting anything.

I am stuck.
I can't find anyone else with the same issue.
Perhaps I should try to request Digium's help ?
dponzone
Newsterisk
 
Posts: 9
Joined: Thu Dec 21, 2006 10:56 pm
Location: Paris, France

Postby wauters » Tue Oct 06, 2009 7:19 pm

Did anyone find an answer to this?
wauters
Newsterisk
 
Posts: 10
Joined: Thu Oct 04, 2007 6:42 pm

Postby sethsdad0627 » Wed Oct 07, 2009 7:15 am

Did you select the right architecture when registering the module?
sethsdad0627
Oldsterisk
 
Posts: 208
Joined: Tue Nov 04, 2008 9:15 am

Re: can't load the modules

Postby jmituzas » Fri Dec 18, 2009 12:42 pm

I bet its the same problem I have 64-bit...
jmituzas
Newsterisk
 
Posts: 41
Joined: Tue Dec 15, 2009 8:43 am


Return to Fax For Asterisk

Who is online

Users browsing this forum: No registered users and 1 guest