cause Segmentation Fault

Community-based Support for users of Free Fax For Asterisk cause Segmentation Fault

Postby alex70 » Thu Jul 09, 2009 4:25 am

Hello guy,

I have just upgraded asterisk from 1.6.1 to 1.6.2.
The problem is that each time I start asterisk, it crashes. Here are the latest messages:

Code: Select all
  == Registered application 'Monitor'
  == Registered application 'StopMonitor'
  == Registered application 'ChangeMonitor'
  == Registered application 'PauseMonitor'
  == Registered application 'UnpauseMonitor'
  == Manager registered action Monitor
  == Manager registered action StopMonitor
  == Manager registered action ChangeMonitor
  == Manager registered action PauseMonitor
  == Manager registered action UnpauseMonitor => (Call Monitoring Resource)
[Jul  9 12:13:02] NOTICE[14155]: res_fax.c:1693 load_module: Generic FAX application module version 1.6.1_1.0.8, Copyright (C) 2008-2009 Digium, Inc
[Jul  9 12:13:02] NOTICE[14155]: res_fax.c:1696 load_module: This module is supplied under a commercial license granted by Digium, Inc.
[Jul  9 12:13:02] NOTICE[14155]: res_fax.c:1697 load_module: Please see the full license text supplied by the accompanying
[Jul  9 12:13:02] NOTICE[14155]: res_fax.c:1698 load_module: "register" utility, or ask for a copy from Digium.
  == Parsing '/etc/asterisk/res_fax.conf':   == Found
  == Registered application 'SendFAX'
  == Registered application 'ReceiveFAX'
Segmentation fault

To make asterisk work I need to remove the and modules. It seems there is some problem right with those two modules. Please note that everything worked with rev. 1.6.1

Any idea to resolve this problem

Thanks indeed!

Posts: 8
Joined: Mon Jul 14, 2008 3:44 am

Postby luca.pretto » Wed Aug 05, 2009 1:10 pm

Same segfault here, on a Debian Lenny X86 box. Asterisk, Fax 1.0.9-i686.

Please help!
Posts: 2
Joined: Sat Aug 01, 2009 2:44 am

Postby luca.pretto » Wed Aug 12, 2009 3:09 am

Trying to upgrade to / 1.0.12
I'll let you know if that solved.
Posts: 2
Joined: Sat Aug 01, 2009 2:44 am

1.6.2 -> same boat

Postby pciccone » Tue Sep 22, 2009 12:57 pm

I'm stuck in the same boat. No pre-compiled fax module seems to have been released yet for 1.6.2. I am thinking that using the 1.6.1 modules are what is causing the segmentation fault.

I cannot find any updates when a 1.6.2 version will be released causing my development efforts to cease.
Posts: 1
Joined: Thu Dec 21, 2006 10:56 pm

Return to Fax For Asterisk

Who is online

Users browsing this forum: No registered users and 1 guest