[RESOLVED] Nearly there!

Community-based Support for users of Free Fax For Asterisk

[RESOLVED] Nearly there!

Postby kenpem » Wed Jun 23, 2010 10:31 am

After days and days of hard grind on this, I'm so close I can taste it!

I'm now at the point where Asterisk is picking up the incoming fax call, and logging as follows:
== Using SIP RTP CoS mark 5
-- Executing [8712867@fax:1] Macro("SIP/sg-fax-00000001", "faxreceive") in new stack
-- Executing [s@macro-faxreceive:1] Set("SIP/sg-fax-00000001", "FAXFILE=/var/spool/asterisk/fax//1277310205.1") in new stack
-- Executing [s@macro-faxreceive:2] Set("SIP/sg-fax-00000001", "EXTEMAIL=") in new stack
-- Executing [s@macro-faxreceive:3] NoOp("SIP/sg-fax-00000001", "") in new stack
-- Executing [s@macro-faxreceive:4] Set("SIP/sg-fax-00000001", "EXTNAME=") in new stack
-- Executing [s@macro-faxreceive:5] NoOp("SIP/sg-fax-00000001", "") in new stack
-- Executing [s@macro-faxreceive:6] Set("SIP/sg-fax-00000001", "EXTCOMPANY=") in new stack
-- Executing [s@macro-faxreceive:7] ReceiveFAX("SIP/sg-fax-00000001", "/var/spool/asterisk/fax//1277310205.1.tif") in new stack
-- Channel 'SIP/sg-fax-00000001' receiving FAX '/var/spool/asterisk/fax//1277310205.1.tif'
-- Channel 'SIP/sg-fax-00000001' FAX session '1' started
[Jun 23 17:23:46] NOTICE[7735]: rtp.c:1143 process_rfc3389: Comfort noise support incomplete in Asterisk (RFC 3389). Please turn off on client if possible. Client IP: 217.10.77.24
-- FAX handle 0: [ 079.229315 ], entering CLOSING state
-- FAX handle 0: [ 079.229361 ], entering CLOSING state
[Jun 23 17:24:46] NOTICE[7735]: res_fax.c:858 generic_fax_exec: Channel 'SIP/sg-fax-00000001' did not return a frame; probably hung up.
-- Channel 'SIP/sg-fax-00000001' FAX session '1' is complete, result: 'SUCCESS' (FAX_SUCCESS), error: 'NO_ERROR', pages: 1, resolution: '204x196', transfer rate: '14400', remoteSID: '+44 115 921 7673'
== Spawn extension (macro-faxreceive, s, 7) exited non-zero on 'SIP/sg-fax-00000001' in macro 'faxreceive'
== Spawn extension (fax, 8712867, 1) exited non-zero on 'SIP/sg-fax-00000001'
-- Executing [h@fax:1] System("SIP/sg-fax-00000001", "/etc/asterisk/scripts/mailfax.sh "" "" "" "" "/var/spool/asterisk/fax//1277310205.1" """) in new stack

However, nothing is actually received. It *appears* as though the sender (a plain old low-tech fax machine on a POTS line) never "hears" any signal tones from Asterisk.

What did I miss?
Last edited by kenpem on Thu Jun 24, 2010 2:58 am, edited 1 time in total.
Asterisk 1.8.1.1 on Ubuntu Server 10.04.1.1 LTS, Linux version 2.6.32-27-generic-pae
http://blog.pembi.net
kenpem
Oldsterisk
 
Posts: 79
Joined: Thu Aug 06, 2009 11:48 am

Re: Nearly there!

Postby kenpem » Thu Jun 24, 2010 2:57 am

Nailed it at last!

The final problem with receipt was the [[macro-faxreceive]] section. I'd already had to modify this to make it 1.6-compatible, replacing SetVar with Set and DBGet with Set xxx=DB(). The first line of the script also had a slash between ${CALLEDFAX} and ${UNIQUEID} which I removed. I also had to add the /fax directory under /var/spool/asterisk and make sure permissions were the same as the other folders.

With my next test-send, a .TIF file appeared! Wheeeee!

Now I've just gotta get it auto-mailed to me, but that's not a fax problem.

Is this something many people battle with? Is it worth me documenting the whole process?
Asterisk 1.8.1.1 on Ubuntu Server 10.04.1.1 LTS, Linux version 2.6.32-27-generic-pae
http://blog.pembi.net
kenpem
Oldsterisk
 
Posts: 79
Joined: Thu Aug 06, 2009 11:48 am

Re: [RESOLVED] Nearly there!

Postby malcolmd » Wed Jul 07, 2010 7:54 am

Howdy,

Were you working with the default configurations out of the manual when you ran across this issue?
Meaning, did the manual incorrectly advise you?
malcolmd
Moves Like Spencer
 
Posts: 3019
Joined: Wed Aug 03, 2005 3:53 pm
Location: Huntsville, AL, US


Return to Fax For Asterisk

Who is online

Users browsing this forum: No registered users and 1 guest