Page 1 of 1

SendFAX not sending content

PostPosted: Thu Jan 05, 2012 2:40 pm
by KingsleyHill
SendFAX is not sending any content over SIP. What am I doing wrong?


I create a valid tif file with:
cat testpdf.pdf | gs -q -sDEVICE=tiffg4 -dBATCH -sPAPERSIZE=a4 -g1680x2285 -dNOPAUSE -sOutputFile=./test.tif - >> test.txt

The tif can be opened with a viewer and it carries all the content.

I create a call file like this:

Channel: SIP/callwithus/19087816047
MaxRetries: 1
WaitTime: 20
Application: SendFAX
Data: /home/kingsley/test.tif,adfzs

I chown it to asterisk:asterisk and mv it to the /var/spool/asterisk/outgoing directory
I have also tried using FlowRoute as the outbound carrier/context with the same result.
ReceiveFAX works fine

Asterisk initiates the call without an issue and connects to the fax machine.

BUT there is no content and no pages sent to the fax machine.

The only messages in the CLI (with verbose at 98) are:

[Jan 5 15:24:56] WARNING[18677]: res_fax.c:2001 sendfax_exec: SendFAX does not support polling
[Jan 5 15:24:56] NOTICE[18677]: pbx_spool.c:349 attempt_thread: Call completed to SIP/callwithus/19087816047