Fax for Asterisk not working

Community-based Support for users of Free Fax For Asterisk

Fax for Asterisk not working

Postby nonlinear314 » Fri Jul 19, 2013 2:38 pm

I purchased a Fax for Asterisk module and cannot receive faxes (I haven't tried sending yet). I have contacted Digium support but they aren't much help when it comes to AsteriskNow since they don't support the FreePBX version it comes with.

I am on a T1 PRI from my telco that goes into a cisco router and from the t1 port of the router to a digium t1 card on a server housing asterisk. I was told by the telco tech that installed the router that they use g.711 for faxing and there shouldn't be any issues. I am using AsteriskNow 3.0

I purchased a fax licence and installed it and the schmooze module for faxing. I made a virtual extension in pbx to be used as a fax destination, enabled fax detection and entered my email address. Then I made an inbound route, turned on fax detection and set it as dahdi. Under Global Settings in dahdi I set fax detection to incoming. I set the destination(s) as Fax Extension and pointed to the new extension.
I tried sending a fax using the fax.com web app and had no luck. I can call the DID line and get the pause but the error from fax.com appears to be a failure to even connect. Digium support attempted to send a fax from their system and said they can see the call in my CLI and theirs (it connects) but it doesn't appear to go anywhere. The tech recommended I create a default fax extension similar to this one:

exten => fax,1,NoOp(**** FAX DETECTED ****)
exten => fax,n,Goto(fax-rx,receive,1)

I checked the fax admin manual and here is the CLI output:

CLI> fax show settings
FAX For Asterisk Settings:
ECM: Enabled
Status Events: Off
Minimum Bit Rate: 2400
Maximum Bit Rate: 14400
Modem Modulations Allowed: V17,V27,V29

FAX Technology Modules:

CLI> fax show version
FAX For Asterisk Components:
Applications: 11.2.1

According to what I've read it is supposed to be straightforward: set up fax extension, create inbound route with fax detection and point it to fax extension, except is isn't working. The tech from Digium said my system appears to be configured correctly.

I did some investigating and it looks like the version of FreePBX that is bundled with AsteriskNow is not generating an ext-fax app? The DID calls ext-fax but ext-fax is nowhere to be found? It is not in extensions.conf, extensions_additional.conf or extensions_custom.conf. This is what is in the extensions_additional.conf file for the DID (0299):

exten => 0299,1,Set(__FROM_DID=${EXTEN})
exten => 0299,n,Gosub(app-blacklist-check,s,1())
exten => 0299,n,Set(CDR(did)=${FROM_DID})
exten => 0299,n,ExecIf($[ "${CALLERID(name)}" = "" ] ?Set(CALLERID(name)=${CALLERID(num)}))
exten => 0299,n,Set(CHANNEL(musicclass)=none)
exten => 0299,n,Set(__MOHCLASS=none)
exten => 0299,n,Set(__CALLINGPRES_SV=${CALLERPRES()})
exten => 0299,n,Set(CALLERPRES()=allowed_not_screened)
exten => 0299,n,Macro(prepend-cid,Fax: )
exten => 0299,n,Set(FAX_DEST=ext-fax^998^1)
exten => 0299,n,Answer
exten => 0299,n,Wait(10)
exten => 0299,n(dest-ext),Goto(ext-fax,998,1)

I am going to create an app in extensions_custom.conf for ext-fax based on the one in the Digium Fax for Asterisk Admin book and see if that fixes it.
Posts: 7
Joined: Fri Jul 19, 2013 9:34 am

Re: Fax for Asterisk not working

Postby nonlinear314 » Fri Jul 19, 2013 4:00 pm

er, context not app my bad.
Posts: 7
Joined: Fri Jul 19, 2013 9:34 am

Re: Fax for Asterisk not working

Postby nonlinear314 » Mon Jul 22, 2013 11:26 am

I got it working without having to mess with any conf files.

Apparently FreePBX wasn't properly loading/starting res_fax_digium.so (I went to reload it after noticing the registered channels was blank and it wasn't found).

I followed the steps in section 2.6 of the Fax for Asterisk Admin Guide starting on page 13 (installing res_fax_digium). I also reloaded/registered license from the command line (instead of FreePBX gui) using section 2.2 of the Fax for Asterisk Admin Guide.

I had to download the proper file from the download site (the generic worked for me):


The only hiccup(s) were that my modules file is located in lib64 instead of lib in the cp command on page 13 and the benchfax utility couldn't be found (didn't need it anyway). Otherwise, I registered the license and loaded the module from the command line then used the FreePBX gui to enable dahdi fax detection, set fax detection to incoming in dahdi global settings, set up the incoming route/DID to accept dahdi faxes, pointed it to the fax extension I created (i.e. edited an extension to accept faxes and supplied and email), and it worked.

Sent the fax to the supplied email.
Posts: 7
Joined: Fri Jul 19, 2013 9:34 am

Return to Fax For Asterisk

Who is online

Users browsing this forum: No registered users and 1 guest