Page 1 of 1

Can't load

PostPosted: Wed Feb 12, 2014 10:09 pm
by redthirtytwo
Hi All,

I'm trialling Asterisk + Digium Fax and have trouble getting the module to load.

I'm running 64-bit CentOS, Asterisk 12.0 installed via the repository (yum). I ran the fax benchmark tool that told me to install the 64-bit Opteron version but that and all the other 64-bit versions give me this error when attempting to load it;

ip-172-31-11-182*CLI> module load res_fax_digium
Unable to load module res_fax_digium
Command 'module load res_fax_digium' failed.
[Feb 13 04:07:32] WARNING[14538]: loader.c:523 load_dynamic_module: Error loading module 'res_fax_digium': /usr/lib64/asterisk/modules/ undefined symbol: ast_verb_sys_level
[Feb 13 04:07:32] WARNING[14538]: loader.c:1032 load_resource: Module 'res_fax_digium' could not be loaded.

Some other details;

[root@ip-172-31-11-182 ~]# uname -a
Linux ip-172-31-11-182 2.6.32-431.5.1.el6.x86_64 #1 SMP Wed Feb 12 00:41:43 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

[root@ip-172-31-11-182 ~]# rpm -qa | grep asterisk

[root@ip-172-31-11-182 modules]# file ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, stripped

ip-172-31-11-182*CLI> module show like fax
Module Description Use Count Status Generic FAX Applications 0 Running
1 modules loaded

Your help would be much appreciated.


Re: Can't load

PostPosted: Wed Mar 26, 2014 8:19 am
by mocking4monk
Hi redthirtytwo

I am getting the same issue , did it get solved?
If yes please share.