FFA Module Load Problem

Community-based Support for users of Free Fax For Asterisk

FFA Module Load Problem

Postby brianbrown » Fri Oct 03, 2014 12:19 pm

I recently have tried to install FFA following the appropriate installation directions, adjusting for a 64 bit installation, and asterisk will not load the fax_res_digium.so module. I get an error:

"undefined symbol: ast_fax_tech_register"

As recommended, I'm using the res_fax_digium-11.0_1.3.1-barcelona_64 and have also tried the generic library as well. Same errors.

Interesting, if I try to put the fax_res.so module in the modules directory and/or manually load it, asterisk crashes, so I'm not using that.

I have searched the forums here and all over but am finding no solution so far.

I'm on CentOS 6.5
Asterisk (Ver. 11.12.0)
FreePBX 12.0.1rc28

Would appreciate any insights anyone can offer!

Posts: 1
Joined: Fri Oct 03, 2014 12:09 pm

Re: FFA Module Load Problem

Postby malcolmd » Fri Oct 03, 2014 1:56 pm

I think you'll need res_fax.so loaded in order to load res_fax_digium.so; also, res_fax_spandsp.so will conflict with res_fax_digium.so, so don't load the two together.
Malcolm Davenport
Digium, Inc. | Senior Product Manager
Moves Like Spencer
Posts: 3019
Joined: Wed Aug 03, 2005 3:53 pm
Location: Huntsville, AL, US

Return to Fax For Asterisk

Who is online

Users browsing this forum: No registered users and 1 guest