AsteriskGUI register string missing: incoming calls to 's'

Get help with installing and running AsteriskNOW.

Moderators: Moderator, Support

AsteriskGUI register string missing: incoming calls to 's'

Postby Rrrr » Wed Sep 05, 2012 7:56 am

Asterisk GUI on Synology DS212+
Linux Server #2228
Asterisk GUI-version : SVN--r

After much trial and error setting up Asterisk GUI, here is my status (and disappointment):

First of all congrats with the GUI, I like it very much versus Freepbx.

Outgoing calls: Working
Incoming calls: Calls are arriving at the 's' extension and get rejected.

Where in the AsteriskGUI can I set a registration string with at the end something like /11111111
Here is my SIP debug ( belongs to the provider)

<--- SIP read from UDP: --->
INVITE sip:s@ SIP/2.0
From: "0650xxxxxx" <sip:0650xxxxxx@>;tag=as7c632521
To: <>
Looking for s in DID_3116xxxxxxx (domain
<--- Reliably Transmitting (NAT) to --->
SIP/2.0 404 Not Found

and the resulting error is:
Call from '3116xxxxxxx' ( to extension 's' rejected because extension not found in context 'DID_3116xxxxxxx'.

I have also done a SIP debug on another Asterisk distribution which terminates the call successfully. The SIP dialog is similar as above, with the difference that it is not looking for s but looking to match the DID number with the one set in the registration string:
Looking for 311xxxxxxx in from-trunk (domain

I am not a specialist, but the difference seems to be the SIP register string which was not done in AsteriskGUI.

Here's what I have tried
1. Editing sip.conf manually with a registration statement led to errors with the GUI.
2. I looked this forum for solutions to the problem with the registration string, to no avail.
3. I have looked into changing the SIP settings for NAT since my Synology (which runs AsteriskGUI) is just a client of a main router behind a cable modem/router (with forwarding rules for all traffic to main router).
I could verify my settings with an existing Asterisk based system: extern ip set to my external IP address or my internal asterisk address), Local network address: NAT mode: Yes Allow RTP invite: NONAT.

Some links I found useful, but unfortunately did not help me: ... 6c#p159617

Any suggestion on how to set register string?
Posts: 1
Joined: Wed Sep 05, 2012 7:41 am

Re: AsteriskGUI register string missing: incoming calls to 's'

Postby franchej » Thu Dec 13, 2012 11:33 am

What version of the GUI are you using.
I had similar issues with my DS 411j but they have since published a new update for the Asterisk package that uses a compatible GUI with

I had to redo most of the config as the original was pointing to the wrong context that the GUI was forcing.
Posts: 16
Joined: Tue Nov 20, 2012 6:18 pm

Re: AsteriskGUI register string missing: incoming calls to 's'

Postby tornblad » Mon Mar 04, 2013 9:54 am

I am running Asterisk 11.2.1 and i had the same problem as you mentions, and setting "registersip=no" and adding "registersip=no" and addind "callbackextension=1234567" in the trunk sectrion of users.conf solved the issue for me! No need to add an extra register => line then. I have two sip trunks from same provider, and this change also made the incoming calls to end up in the correct context. Before this change both calls ended up in the first trunks context.

Not setting registersip=no caused the trunk to register twice and probably confusing the provider on how to call back, not sure if i made some misstakes or if this is should be reported as a bug!

One other strange thing is that in the CDR the incoming calls shows as "s", but in the incoming dialing rules it matches the number I added to callbackextension.

Not sure if this works the same way in 1.8, but might be worth testing.
Posts: 2
Joined: Mon Mar 04, 2013 5:13 am

Return to AsteriskNOW Support

Who is online

Users browsing this forum: No registered users and 1 guest