Inbound skype calls cause segmentation faults

A forum for Skype For Asterisk users to ask questions and get advice from other users

Moderators: twilson, pete engler

Inbound skype calls cause segmentation faults

Postby echamberlain » Thu Jul 30, 2009 4:54 pm

Is anyone else getting segmentation faults when inbound skype calls are answered?
echamberlain
Newsterisk
 
Posts: 5
Joined: Thu Jul 30, 2009 12:28 pm

Postby Docteh » Thu Jul 30, 2009 5:14 pm

I have incoming call segfaults with 1.6.1.1 when the call goes to Playback, but routing the call to Dial(SIP/peer) works, I installed 1.4 and matching SFA and all is well.
Docteh
Newsterisk
 
Posts: 47
Joined: Thu Jul 30, 2009 10:52 am

Postby echamberlain » Thu Jul 30, 2009 5:29 pm

I'm getting seg faults on both inbound and outbound skype calls as soon as the call is answered.

http://betareports.digium.com/mantis/view.php?id=11
echamberlain
Newsterisk
 
Posts: 5
Joined: Thu Jul 30, 2009 12:28 pm

Postby ianplain » Thu Jul 30, 2009 5:33 pm

Hi

1.4.26 works fine , Playbacks OK audio OK dtmf to incoming IVRs OK

Ian
ianplain
Moves Like Spencer
 
Posts: 3089
Joined: Thu Dec 14, 2006 7:01 am
Location: Bath, UK

Postby twilson » Fri Jul 31, 2009 8:55 am

I am assuming you are using one of the 1.6.1 releases. Asterisk 1.6.1 versions < 1.6.1.2 (which hasn't been released yet) have a bug that SFA exposes. If you download 1.6.1 from subversion, this bug is fixed. svn co http://svn.digium.com/svn/asterisk/branches/1.6.1
twilson
Oldsterisk
 
Posts: 87
Joined: Mon Jun 01, 2009 9:35 am


Return to Skype For Asterisk

Who is online

Users browsing this forum: No registered users and 1 guest