Skype engine failed to start.

A forum for Skype For Asterisk users to ask questions and get advice from other users

Moderators: twilson, pete engler

Skype engine failed to start.

Postby pmaartense » Fri Jul 31, 2009 3:58 am

after compiling against 1.4.23.1 on 64b Suse everthing compiles fine but have following errors and notices in the Log

[Jul 30 21:02:26] VERBOSE[4270] logger.c: Loading Skype For Asterisk engine
[Jul 30 21:02:26] NOTICE[4270] res_skypeforasterisk.c: Skype For Asterisk module, Copyright (C) 2008-2009 Digium, Inc.
[Jul 30 21:02:26] NOTICE[4270] res_skypeforasterisk.c: This module is supplied under a commercial license granted by Digium, Inc.
[Jul 30 21:02:26] NOTICE[4270] res_skypeforasterisk.c: Please see the full license text supplied by the accompanying
[Jul 30 21:02:26] NOTICE[4270] res_skypeforasterisk.c: "register" utility, or ask for a copy from Digium.
[Jul 30 21:02:26] NOTICE[4270] res_skypeforasterisk.c: This product includes software developed by the OpenSSL Project
[Jul 30 21:02:26] NOTICE[4270] res_skypeforasterisk.c: for use in the OpenSSL Toolkit. (http://www.openssl.org/)
[Jul 30 21:02:26] NOTICE[4270] res_skypeforasterisk.c: Copyright (C) 1998-2008 The OpenSSL Project
[Jul 30 21:02:26] VERBOSE[4270] logger.c: res_skypeforasterisk.so => (Skype For Asterisk Engine)
[Jul 30 21:02:26] VERBOSE[4270] logger.c: == Parsing '/etc/asterisk/chan_skype.conf': [Jul 30 21:02:26] VERBOSE[4270] logger.c: Found
[Jul 30 21:02:26] DEBUG[4270] core.cpp: License directory set to: /var/lib/asterisk/licenses
[Jul 30 21:02:26] NOTICE[4270] core.cpp: Found license 'S4AB-HAB5JHX8QLGW' providing 10 concurrent calls
[Jul 30 21:02:26] NOTICE[4270] core.cpp: Skype For Asterisk Host-ID: *****
[Jul 30 21:02:26] NOTICE[4270] core.cpp: Found a total of 10 Skype For Asterisk licenses
[Jul 30 21:02:26] DEBUG[4283] core.cpp: starting skypewatcher as: skypewatcher 4284
[Jul 30 21:02:26] DEBUG[4284] core.cpp: starting skyhost as: skypeforasterisk -z -f /var/spool/asterisk/skype/data -d /var/spool/asterisk/skype/skyhost-debug
[Jul 30 21:02:26] DEBUG[4284] core.cpp: skyhost environment is : HOME=/var/spool/asterisk/skype
[Jul 30 21:02:27] DEBUG[4282] core.cpp: got SkyHost Copyright (C) 2003-2008 Skype Technologies S.A.
[Jul 30 21:02:27] DEBUG[4282] core.cpp: got Proprietary and confidential, do not share this application.
[Jul 30 21:02:27] DEBUG[4282] core.cpp: pfd 0 had an error
[Jul 30 21:02:27] DEBUG[4282] core.cpp: sending SIGTERM to 4283.
[Jul 30 21:02:36] ERROR[4270] core.cpp: Skype engine failed to start.
[Jul 30 21:02:36] ERROR[4270] chan_skype.c: Unable to start Skype For Asterisk library.
[Jul 30 21:02:36] VERBOSE[4270] logger.c: == Manager registered action SkypeBuddies
[Jul 30 21:02:36] VERBOSE[4270] logger.c: == Manager registered action SkypeBuddy
[Jul 30 21:02:36] VERBOSE[4270] logger.c: == Manager registered action SkypeAccountProperty
[Jul 30 21:02:36] VERBOSE[4270] logger.c: == Manager registered action SkypeAddBuddy
[Jul 30 21:02:36] VERBOSE[4270] logger.c: == Manager registered action SkypeRemoveBuddy
[Jul 30 21:02:36] VERBOSE[4270] logger.c: == Manager registered action SkypeLicenseStatus
[Jul 30 21:02:36] VERBOSE[4270] logger.c: == Manager registered action SkypeLicenseList
[Jul 30 21:02:36] VERBOSE[4270] logger.c: == Registered custom function SKYPE_CALL_PROPERTY
[Jul 30 21:02:36] VERBOSE[4270] logger.c: == Registered custom function SKYPE_ACCOUNT_PROPERTY
[Jul 30 21:02:36] VERBOSE[4270] logger.c: == Registered custom function SKYPE_BUDDIES
[Jul 30 21:02:36] VERBOSE[4270] logger.c: == Registered custom function SKYPE_BUDDY_FETCH
[Jul 30 21:02:36] VERBOSE[4270] logger.c: chan_skype.so => (Skype For Asterisk Channel Driver)
---------------------

futhermore


skype show version
Skype For Asterisk Components:
Channel Driver: 1.4_0.9.10
Library: UNKNOWN_and_probably_unsupported
pmaartense
Newsterisk
 
Posts: 1
Joined: Fri Jul 31, 2009 3:51 am

Postby twilson » Fri Jul 31, 2009 8:46 am

You might check after exiting Asterisk with ps aux|grep skype to see if there are any skypeforasterisk processes hung. If there are, then the next time that Asterisk loads chan_skype.so, it will try to bind to the same ports as the hung process. You have to kill (or kill -9) the skypeforasterisk process by process id (killall won't work).

You might also try using Asterisk 1.4 >= 1.4.25.
twilson
Oldsterisk
 
Posts: 87
Joined: Mon Jun 01, 2009 9:35 am

Sype problem

Postby romina467diestro » Mon Aug 03, 2009 6:36 pm

I got the same got the same problem but i will try what u said.
thanks.

desarrollo de aplicaciones web
romina467diestro
Newsterisk
 
Posts: 1
Joined: Mon Aug 03, 2009 6:32 pm


Return to Skype For Asterisk

Who is online

Users browsing this forum: No registered users and 1 guest

cron