Cannot handle TLS data

A forum for Skype For Asterisk users to ask questions and get advice from other users

Moderators: twilson, pete engler

Cannot handle TLS data

Postby aare » Fri Jul 31, 2009 2:07 pm

Hello!

Build for skypeforasterisk-1.4_0.9.11-x86_32 went ok, but built modules won't load:

*CLI> module load res_skypeforasterisk
[Jul 31 22:35:09] WARNING[23475]: loader.c:368 load_dynamic_module: Error loading module 'res_skypeforasterisk': libstdc++.so.6: cannot handle TLS data
[Jul 31 22:35:09] WARNING[23475]: loader.c:721 load_resource: Module 'res_skypeforasterisk' could not be loaded.
*CLI> module load chan_skype
[Jul 31 22:35:12] WARNING[23475]: loader.c:409 load_dynamic_module: Error loading module 'chan_skype': /custom/usr/lib/asterisk/modules/chan_skype.so: undefined symbol: sfa_license_filename
[Jul 31 22:35:12] WARNING[23475]: loader.c:721 load_resource: Module 'chan_skype' could not be loaded.


As I see the error produced by res_skypeforasterisk.so shows that there is some incompatibility with system libstdc++.so.6.
How to solve this?

Platform:
i386/i686
Red Hat Enterprise Linux ES release 4 (Nahant Update 8)
Asterisk 1.4.26
gcc-c++-3.4.6-11
libstdc++-devel-3.4.6-11
libstdc++-3.4.6-11


TIA
aare
Newsterisk
 
Posts: 2
Joined: Fri Jul 31, 2009 7:19 am

Postby marcin82w » Sat Aug 01, 2009 10:38 am

Hi

I have the same problem

messages:

[Aug 1 17:02:41] WARNING[26812] loader.c: Error loading module 'res_skypeforasterisk.so': libstdc++.so.6: cannot handle TLS data
[Aug 1 17:02:41] WARNING[26812] res_smdi.c: No SMDI interfaces are available to listen on, not starting SMDI listener.
[Aug 1 17:02:41] WARNING[26812] loader.c: Error loading module 'res_skypeforasterisk.so': libstdc++.so.6: cannot handle TLS data
[Aug 1 17:02:41] WARNING[26812] loader.c: Module 'res_skypeforasterisk.so' could not be loaded.
[Aug 1 17:02:41] WARNING[26812] loader.c: Error loading module 'chan_skype.so': /usr/lib/asterisk/modules/chan_skype.so: undefined symbol: sfa_license_filename
[Aug 1 17:02:41] WARNING[26812] loader.c: Module 'chan_skype.so' could not be loaded.


Regards
Marcin
marcin82w
Newsterisk
 
Posts: 4
Joined: Sat Aug 01, 2009 9:50 am

Postby twilson » Mon Aug 03, 2009 9:48 am

Hmm, is it possible that you have the LD_ASSUME_KERNEL environment variable set?

I found this post: http://www.mail-archive.com/debian-bugs ... 50160.html that seems to have a similar sounding issue.
twilson
Oldsterisk
 
Posts: 87
Joined: Mon Jun 01, 2009 9:35 am

Postby aare » Mon Aug 03, 2009 1:39 pm

Yes, thanks for the hint!
Problem solved :)

Regards,
Aare
aare
Newsterisk
 
Posts: 2
Joined: Fri Jul 31, 2009 7:19 am


Return to Skype For Asterisk

Who is online

Users browsing this forum: No registered users and 1 guest