Engine crashes after 1 call

A forum for Skype For Asterisk users to ask questions and get advice from other users

Moderators: twilson, pete engler

Engine crashes after 1 call

Postby morchea » Sun Sep 27, 2009 7:20 am

Hi,
I am using Asterisk 1.4.26.2 on a x86_64 Fedora Core 10
Channel Driver: 1.4_1.0.2
Library: 1.4_1.0.2

After 1 call, engine crashes and I need to restart asterisk to make it work again.

Sep 27 14:21:42] NOTICE[23750] core.cpp: ending call
[Sep 27 14:25:24] WARNING[8623] core.cpp: sending SIGTERM to 8624 failed with No such process
[Sep 27 14:25:24] WARNING[8632] chan_skype.c: fd 34 had an error, marking broken and queuing rebuild

I didn't have this running on a 32 bits FC10...
Can anyone please assist, I could not open a case at Digium on their website.
Cheers,

Morchea
morchea
Newsterisk
 
Posts: 6
Joined: Sun Sep 27, 2009 7:14 am

Postby morchea » Sun Sep 27, 2009 8:26 am

Even better,

I was on the asterisk CLI during a Skype call to asterisk. On a "quit" CLI, skype call crashed... I'm really getting worried about the stability here...

Morchea.
morchea
Newsterisk
 
Posts: 6
Joined: Sun Sep 27, 2009 7:14 am

Postby twilson » Mon Sep 28, 2009 1:34 pm

There were several issues with the 1.0.2 release. 1.0.5 has just been posted to the website. Please try it out--I think you will find it much better. (Be sure to restart asterisk after doing the install--or at the very least unload both res_skypeforasterisk.so and chan_skype.so and then load them with res_skypeforasterisk.so being the first).
twilson
Oldsterisk
 
Posts: 87
Joined: Mon Jun 01, 2009 9:35 am

Postby morchea » Tue Sep 29, 2009 1:26 am

Hey, I did the upgrade, but it does not help.

Skype crashes when I "exit" asterisk CLI ...
I have opened bug with DIgium..

Morchea.
morchea
Newsterisk
 
Posts: 6
Joined: Sun Sep 27, 2009 7:14 am

Postby ManChicken » Tue Sep 29, 2009 1:59 am

I think I had the same thing happen just now (running 1.0.5); I was connected to the console (asterisk -rvvv) and poking around, everything Skype-wise was working, but after I 'quit' the console all the skypeforasterisk servers were gone (it seems to run quite a lot them, I have 11 showing up in ps right now, is that normal?)

I'm trying to duplicate it but so far haven't been able to.
ManChicken
Newsterisk
 
Posts: 29
Joined: Mon Mar 10, 2008 3:59 pm

Postby twilson » Tue Sep 29, 2009 7:43 am

It is normal for there to be lots of "processes". They are actually threads, but Skype's software uses old-style linux threads which look like processes. I seem to remember that each user brings 6-7 threads + some startup threads.

I am unable to reproduce the issue you mention. Run asterisk, connect w/ asterisk -rvvv. made some calls, typed quit, all my skypeforasterisk processes stayed up, I could reconnect and skype show users showed the user logged in.

Best to open a ticket with Digium. If support can't figure it out, it will make its way to me fairly quickly. They will collect all of the debug information that I should need.
twilson
Oldsterisk
 
Posts: 87
Joined: Mon Jun 01, 2009 9:35 am

Postby morchea » Wed Sep 30, 2009 12:28 pm

So, release. 1.0.5 seems to have solved the issues with Skype hanging after the 1st succesfull call. But I still crash the calls when I quit the asterisk CLI !!! Still have an open ticket with Digium with no reply yet after traces submit.

Morchea.
morchea
Newsterisk
 
Posts: 6
Joined: Sun Sep 27, 2009 7:14 am


Return to Skype For Asterisk

Who is online

Users browsing this forum: No registered users and 1 guest

cron