Digium Phones Config broken after update

Community based support for the Digium Phone Application Programming Interface (API).

Moderators: jwitt, sruffell, malcolmd, Moderator

Digium Phones Config broken after update

Postby levimill » Mon Nov 04, 2013 12:28 pm

Running AsteriskNOW 3.0 and recently applied the Digium Phones Config update (2.11.0.6) but now the module is listed as broken, and it's also still listed as being version 2.11.0.5. I updated it along side a few other modules, and they all seem fine. I didn't want to uninstall the module and reinstall it, for fear of losing all of my phone configs.
levimill
Newsterisk
 
Posts: 36
Joined: Mon Mar 04, 2013 4:03 pm

Re: Digium Phones Config broken after update

Postby malcolmd » Mon Nov 04, 2013 12:55 pm

Howdy,

Please open an issue here - https://issues.asterisk.org/jira/browse/ANOW

Cheers
Malcolm Davenport
Digium, Inc. | Senior Product Manager
malcolmd
Moves Like Spencer
 
Posts: 3019
Joined: Wed Aug 03, 2005 3:53 pm
Location: Huntsville, AL, US

Re: Digium Phones Config broken after update

Postby levimill » Tue Nov 05, 2013 10:15 am

I'm certainly no developer, nor would I even consider myself a tester. I opened a case in JIRA anyway.

Further to my initial post: I was able to uninstall the broken Digium Phones Config module, manually remove the module's directory, then reinstall the latest version (2.11.0.6) without any loss of config. Once the new version was installed and registered, everything was back to normal.
levimill
Newsterisk
 
Posts: 36
Joined: Mon Mar 04, 2013 4:03 pm

Re: Digium Phones Config broken after update

Postby malcolmd » Wed Nov 06, 2013 11:30 am

Any idea how you got into that state? If we can replicate it using exact steps, it'd be much easier to troubleshoot and potentially resolve.

Cheers
Malcolm Davenport
Digium, Inc. | Senior Product Manager
malcolmd
Moves Like Spencer
 
Posts: 3019
Joined: Wed Aug 03, 2005 3:53 pm
Location: Huntsville, AL, US

Re: Digium Phones Config broken after update

Postby gob » Thu Nov 07, 2013 11:30 am

FYI
I have the same scenario.
Tried the FreePBX online update for the module from 2.11.0.5 to 2.11.0.6 and it reported that it couldn't uninstall the previous version. After refreshing the module admin page it reports the Digium Phones Config module is broken and it has been removed from the connectivity menu.

I will try the fix that levimill suggests.
gob
Newsterisk
 
Posts: 5
Joined: Thu Jun 20, 2013 3:43 am

Re: Digium Phones Config broken after update

Postby malcolmd » Tue Nov 12, 2013 12:30 pm

Howdy,

Anyone have a backup of a broken situation that we could then load onto a system here to try and replicate? We haven't run into it yet.

Cheers
Malcolm Davenport
Digium, Inc. | Senior Product Manager
malcolmd
Moves Like Spencer
 
Posts: 3019
Joined: Wed Aug 03, 2005 3:53 pm
Location: Huntsville, AL, US

Re: Digium Phones Config broken after update

Postby gob » Tue Nov 12, 2013 12:59 pm

Afraid not, however I found that the module couldn't be removed because of a firmware folder that was inside the module folder.
The firmware I downloaded through the Digium Phones GUI but the config file for that firmware was broken.
I tried to fix it manually but I never actually managed to get the firmware to install on a handset.

Perhaps the firmware has subsequently been fixed hence you are unable to replicate the issue?
gob
Newsterisk
 
Posts: 5
Joined: Thu Jun 20, 2013 3:43 am

Re: Digium Phones Config broken after update

Postby malcolmd » Tue Nov 12, 2013 1:06 pm

Ahh...okay, that's a reasonable line of thought. We did have an error in a firmware file that we fixed. Hopefully that's the only thing going on here (and that would explain why we couldn't replicate it, since you can't get into that state anymore).
Malcolm Davenport
Digium, Inc. | Senior Product Manager
malcolmd
Moves Like Spencer
 
Posts: 3019
Joined: Wed Aug 03, 2005 3:53 pm
Location: Huntsville, AL, US

Re: Digium Phones Config broken after update

Postby levimill » Tue Nov 12, 2013 1:10 pm

Sounds likely to me. I also had the issue with the broken firmware package awhile back.
levimill
Newsterisk
 
Posts: 36
Joined: Mon Mar 04, 2013 4:03 pm


Return to Digium Phone API

Who is online

Users browsing this forum: No registered users and 1 guest