Smart BLF doesn't work

Community based support for the Digium Phone Application Programming Interface (API).

Moderators: jwitt, sruffell, malcolmd, Moderator

Smart BLF doesn't work

Postby yann0573 » Tue May 13, 2014 2:48 pm

Hi folks,

I am trying to use smart blf on my D50 phone.

1. I succeeded loading smart blf configuration file
2. The contact is assigned to the required button.
3. I am able to execute predefined action

Problems:

1. It seems like my phone doesn't see the target phone's state. Only target_status="unknown" works
2. The indicators don't work either. Even if I define target_status="uknown"

Bellow example of the contacts and blf file:

contacts file:


<?xml version="1.0" ?>
<phonebooks>
<contacts
group_name="internal-543"
editable="0">
<contact id="147" first_name="Tom" last_name="A" organization="" contact_type="sip" account_id="147" subscribe_to="auto_hint_147"
has_voicemail="1">
<actions>
<action id="regular_dial" dial="147" dial_prefix="" label="regular_dial" name="regular_dial"/>
<action id="call_vm" dial="449" dial_prefix="" label="call_vm" name="call_vm"/>
</actions>
</contact>
</contacts>
</phonebooks>


BLF file:

<?xml version="1.0">
<config>
<smart_blf>
<blf_items>
<blf_item location="main" index="1" paging="0" contact_id="147">
<behaviors>
<behavior phone_state="idle" target_status="idle" press_action="regular_dial" press_function="dial" />
<behavior phone_state="idle" target_status="unknown" press_action="call_vm" press_function="dial" />
</behaviors>
<indicators>
<indicator target_status="idle" ring="0" ringtone_id="Digium" led_color="green" led_state="fast" />
<indicator target_status="unknown" ring="0" ringtone_id="Digium" led_color="red" led_state="fast" />
</indicators>
</blf_item>
</blf_items>

</smart_blf>
</config>

Any ideas?

Thank you in advance.
yann0573
Newsterisk
 
Posts: 3
Joined: Wed Sep 04, 2013 10:34 am

Return to Digium Phone API

Who is online

Users browsing this forum: No registered users and 1 guest