Asterisk incomming call issue

General discussions about Asterisk.

Moderators: Moderator, Support

Asterisk incomming call issue

Postby ladio » Wed Oct 15, 2008 10:03 pm

Greetings everyone,

I'm new to Asterisk and i have a very basic issue (I guess) which is driving me crazy.
I have installed Asterisk 1.4 with B410p ISDN card. The installation went fine. What i want to do is when someone calls the isdn number, i want to implement follow me feature.
Since i'm new to configuring asterisk, i thought of starting with the basics:if a call comes in, play a welcome greeting and hang up.

The following is the code of the extensions.conf:
Code: Select all
[general]
static=yes
writeprotect=no
clearglobalvars=no

[globals]
CONSOLE=Console/dsp                             ; Console interface for demo
IAXINFO=guest                                   ; IAXtel username/password
TRUNK=Zap/G2                                    ; Trunk interface
TRUNKMSD=1                                      ; MSD digits to strip (usually 1 or 0)

[demo]
exten => s,1,Wait(1)
exten => s,2,Answer
exten => s,3,Playback(demo-congrats)
exten => s,4,Hangup


The following is the content of misdn.conf:

Code: Select all
[general]
misdn_init=/etc/misdn-init.conf
debug=2
ntdebugflags=0
ntdebugfile=/var/log/misdn-nt.log
ntkeepcalls=no
bridging=no
l1watcher_timeout=0
stop_tone_after_first_digit=yes
append_digits2exten=yes
dynamic_crypt=no
crypt_prefix=**
crypt_keys=test,muh

[default]
context=demo
language=en
musicclass=default
senddtmf=yes
far_alerting=no
allowed_bearers=all
nationalprefix=0
internationalprefix=00
rxgain=0
txgain=0
te_choose_channel=no
pmp_l1_check=no
reject_cause=16
need_more_infos=no
nttimeout=no
method=standard
overlapdial=yes
dialplan=0
localdialplan=0
cpndialplan=0
early_bconnect=yes
incoming_early_audio=no
nodialtone=no
presentation=-1
screen=-1
echotraining=no
jitterbuffer=4000
jitterbuffer_upper_threshold=0
hdlc=no
max_incoming=-1
max_outgoing=-1

[TE]
ports=1,2
context=demo
msns=*


When i dail the isdn number, i simply hear the dialing tone and that's all. The following is what i see in the CLI:
Code: Select all
P[ 1] channel with stid:0 for one second still in use!
P[ 1] I IND :NEW_CHANNEL oad:019xxxxxxx dad:03xxxxxxxx pid:3 state:none
P[ 1]  --> channel:1 mode:TE cause:16 ocause:16 rad: cad:
P[ 1]  --> info_dad: onumplan:0 dnumplan:2 rnumplan:  cpnnumplan:0
P[ 1] Chan not existing at the moment bc->l3id:2000f bc:0x88f6cac event:NEW_CHANNEL port:1 channel:1
P[ 1] NO USERUESRINFO
P[ 1]  --> TRANSPARENT Mode
P[ 1] I IND :SETUP oad:019xxxxxxx dad:03xxxxxxxx pid:3 state:none
P[ 1]  --> channel:1 mode:TE cause:16 ocause:16 rad: cad:
P[ 1]  --> info_dad: onumplan:0 dnumplan:2 rnumplan:  cpnnumplan:0
P[ 1]  --> Bearer: Speech
P[ 1]  --> Codec: Alaw
P[ 1]  --> Bearer: Speech
P[ 1]  --> Codec: Alaw
P[ 0]  --> * NEW CHANNEL dad:03xxxxxxxx oad:019xxxxxxx
P[ 1] read_config: Getting Config
P[ 1]  --> CTON: Unknown
P[ 1]  --> PRES: Restricted (0)
P[ 1]  --> SCREEN: Unscreened (0)
P[ 1] I SEND:RELEASE oad:019xxxxxxx dad:003xxxxxxxx pid:3
P[ 1]  --> channel:1 mode:TE cause:16 ocause:1 rad: cad:
P[ 1]  --> info_dad: onumplan:0 dnumplan:2 rnumplan:  cpnnumplan:0
P[ 1] I IND :RELEASE_COMPLETE oad:019xxxxxxx dad:003xxxxxxxx pid:3 state:EXTCANTMATCH
P[ 1]  --> channel:1 mode:TE cause:16 ocause:1 rad: cad:
P[ 1]  --> info_dad: onumplan:0 dnumplan:2 rnumplan:  cpnnumplan:0
P[ 1]  --> hangup
P[ 1] * IND : HANGUP    pid:3 ctx:demo dad:003xxxxxxxx oad:019xxxxxxx State:EXTCANTMATCH
P[ 1]  --> out_cause:16
P[ 1]  --> state:EXTCANTMATCH
P[ 1] $$$ Cleaning up bc with stid :10010100 pid:3


I really really appreciate some help as i spent few days to understand why this thing doesn't work and i'm still stuck.

Thanks in advance,
Ladio
ladio
Newsterisk
 
Posts: 11
Joined: Wed Aug 27, 2008 7:17 am

Postby mbruni » Thu Oct 16, 2008 2:29 am

oad:019xxxxxxx State:EXTCANTMATCH

In the demo context don't use the s extension, try use the number dialed (019xxxxxxx) as the extension or a catch all extension pattern like "_X.".

Cheers.

Marco Bruni
mbruni
Astmaster
 
Posts: 957
Joined: Thu Dec 21, 2006 10:56 pm
Location: Arezzo, Italy

Postby ladio » Thu Oct 16, 2008 5:46 am

Marco,

I really don't know how to thank you! You really saved lots of my time and nerves. THANKS A LOT!!!

cheers
Ladio
ladio
Newsterisk
 
Posts: 11
Joined: Wed Aug 27, 2008 7:17 am


Return to Asterisk General

Who is online

Users browsing this forum: No registered users and 1 guest