sip trunk no sound

General discussions about Asterisk.

Moderators: Moderator, Support

sip trunk no sound

Postby RDouro » Wed May 21, 2014 5:31 pm

hello to all

I have a problem when using a sip trunk
to make a call by sip trunk hear the call signal person meets the other side but I did not hear the voice.

I use Asterisk 11.1.2 on centos 6 have the firewall opened with udp / tcp 5060 and udp 10000:20000

Cosola in the asterisk of this result:
- SIP/441002-00000024 is making progress passing it to SIP/20097-00000023
     - SIP/441002-00000024 is ringing
     - SIP/441002-00000024 answered SIP/20097-00000023
     - Locally bridging SIP/20097-00000023 and SIP/441002-00000024
     - Locally bridging SIP/20097-00000023 and SIP/441002-00000024
   == Spawn extension (default, numberoffphone, 1) exited non-zero on 'SIP/20097-00000023'

can anyone help

Greetings :?
RDouro
Newsterisk
 
Posts: 38
Joined: Tue Jan 10, 2012 8:28 am
Location: Portugal

Re: sip trunk no sound

Postby david55 » Thu May 22, 2014 12:53 am

This will be a firewall or NAT issue.

Note, please use Asterisk Support for future support requests.
david55
Moves Like Spencer
 
Posts: 12570
Joined: Fri Sep 26, 2008 5:03 am

Re: sip trunk no sound

Postby RDouro » Fri May 23, 2014 3:26 am

hello to all

I use centos 6 with asterisk 11.1.2 I opened the firewall tcp 5060
and rdp 10000:20000!

Can someone help configure iptables nat

regards
RDouro
Newsterisk
 
Posts: 38
Joined: Tue Jan 10, 2012 8:28 am
Location: Portugal

Re: sip trunk no sound

Postby ambiorixg12 » Sat May 24, 2014 6:31 pm

run this command rtp set debug on and check the media stream address
ambiorixg12
Astmaster
 
Posts: 967
Joined: Sun Mar 04, 2007 9:32 pm
Location: Dominican Republic

Re: sip trunk no sound

Postby RDouro » Thu Jul 09, 2015 1:04 pm

hi ,

open the doors in my firewall tcp 5060 to ip machine and rtp port 10000-20000

bur see when i make comand rdp set debug on
Sent RTP packet to 192.168.0.16:10096 (type 00, seq 051700, ts 012224, len 000160)
Got RTP packet from 89.26.246.158:13808 (type 00, seq 036774, ts 012384, len 000160)
Sent RTP packet to 192.168.0.16:10096 (type 00, seq 051701, ts 012384, len 000160)

regards,
RDouro
Newsterisk
 
Posts: 38
Joined: Tue Jan 10, 2012 8:28 am
Location: Portugal

Re: sip trunk no sound

Postby ambiorixg12 » Fri Jul 10, 2015 12:26 am

RTP ports are UDP not TCP. and the audio is flowing between this 2 addresses

Sent RTP packet to 192.168.0.16:10096 (type 00, seq 051700, ts 012224, len 000160)
Got RTP packet from 89.26.246.158:13808 (type 00, seq 036774, ts 012384, len 000160)

Check your nat setting in your sip.conf file, and also a full sip trace will help you
ambiorixg12
Astmaster
 
Posts: 967
Joined: Sun Mar 04, 2007 9:32 pm
Location: Dominican Republic

Re: sip trunk no sound

Postby striker24x7 » Mon Jul 13, 2015 8:28 am

put
externip=your--public--ip in sip.conf
reload and check the calls
best regards
http://www.striker24x7.blogspot.com
striker
skypeid |gtalk : striker24x7
striker24x7
Newsterisk
 
Posts: 40
Joined: Wed Dec 29, 2010 3:07 am
Location: INDIA


Return to Asterisk General

Who is online

Users browsing this forum: Google [Bot] and 1 guest