PJSIP and Cisco 79XX phones not registering

Get help with installing, upgrading and running Asterisk.

Moderators: muppetmaster, Moderator, Support

PJSIP and Cisco 79XX phones not registering

Postby krunner » Wed Oct 29, 2014 12:30 pm

Does pjsip support Cisco 79XX series phones. I have had no luck in getting these devices to register with pjsip. Has anyone out there been able to get these phones working with pjsip?
krunner
Newsterisk
 
Posts: 7
Joined: Thu Mar 27, 2014 12:53 pm

Re: PJSIP and Cisco 79XX phones not registering

Postby laschalkh » Mon Dec 15, 2014 10:16 am

I'm having a problem with a 7960 as well. Keep getting 401 Unauthorized. Tried switching to chan_sip as well. Still no good. Has anyone been able to get this to work lately?
laschalkh
Newsterisk
 
Posts: 1
Joined: Mon Dec 15, 2014 10:15 am

Re: PJSIP and Cisco 79XX phones not registering

Postby bwilks » Sun May 17, 2015 10:15 pm

Hi, I have the same problem did you find a solution.

I have Cisco 7940 and Asterisk 13 and the Cisco 7940's won't register.

Thanks
bwilks
Oldsterisk
 
Posts: 235
Joined: Sat Nov 25, 2006 5:38 am
Location: Brisbane, Australia

Re: PJSIP and Cisco 79XX phones not registering

Postby david55 » Mon May 18, 2015 3:03 am

Generally you need to provide debugging information, but, in particular, I would note that failing to get beyond 401 generally indicates a misconfiguration of the authorisation data in the phones.

Also, it is not possible to say that you have the same problem on the basis of the information provided here; there isn't enough information to work out what the problem is!
david55
Moves Like Spencer
 
Posts: 12570
Joined: Fri Sep 26, 2008 5:03 am

Re: PJSIP and Cisco 79XX phones not registering

Postby jcolp » Tue May 19, 2015 7:02 am

This is caused by res_pjsip defaulting to "yes" for force_rport. This option is compatible with pretty much everything but some of the Cisco SIP stacks. It causes SIP responses to go back to the source IP address and port, which is useful for NAT. In the case of Cisco however they send their messages from a randomized source port which drops traffic sent to it. The fix is to set "force_rport=no" for any endpoints which are Cisco phones.
Joshua Colp
Digium, Inc. | Senior Software Developer
jcolp
Oldsterisk
 
Posts: 248
Joined: Tue May 19, 2015 6:59 am


Return to Asterisk Support

Who is online

Users browsing this forum: Exabot [Bot] and 1 guest