SNOM 360 Strange Voicemail Behaviour

Get help with installing, upgrading and running Asterisk.

Moderators: muppetmaster, Moderator, Support

SNOM 360 Strange Voicemail Behaviour

Postby danielkelly » Tue Apr 03, 2007 11:18 pm

I am running Asterisk v1.12 and am having problems getting a single SNOM Phone to work correctly for voicemail.

Basically i have setup the sip.conf as follows :-

[11]
type=friend
secret=xxx
qualify=yes
nat=no
host=dynamic
mailbox=511@xxx-voicemail
vmexten=511
canreinvite=no
context=internal

[15]
type=friend
secret=xxx
qualify=yes
nat=no
host=dynamic
mailbox=515@xxx-voicemail
vmexten=515
canreinvite=no
context=internal

The vmexten line should tell it that the Voicemail Account is 5xx. Extension 15 works perfectly. in the sip trace on the SNOM360 i get

Received from udp:192.168.32.222:5060 at 4/4/2007 14:59:22:570 (581 bytes):

NOTIFY sip:15@192.168.32.100:2054;line=ydg4eu9f SIP/2.0
Via: SIP/2.0/UDP 192.168.32.222:5060;branch=z9hG4bK7abdb65a;rport
From: "asterisk" <sip:asterisk@192.168.32.222>;tag=as34e45318
To: <sip:15@192.168.32.100:2054;line=ydg4eu9f>
Contact: <sip:asterisk@192.168.32.222>
Call-ID: 158754757c63f1d26b80df6a6d323796@192.168.32.222
CSeq: 102 NOTIFY
User-Agent: Asterisk PBX
Max-Forwards: 70
Event: message-summary
Content-Type: application/simple-message-summary
Content-Length: 90

Messages-Waiting: yes
Message-Account: sip:515@192.168.32.222
Voice-Message: 1/0 (0/0)


However with Extension 11, i get the following :-

Received from udp:192.168.32.222:5060 at 4/4/2007 15:02:17:670 (586 bytes):

NOTIFY sip:11@192.168.32.104:2063;line=4dbo4cqy SIP/2.0
Via: SIP/2.0/UDP 192.168.32.222:5060;branch=z9hG4bK56dab3e1;rport
From: "asterisk" <sip:asterisk@192.168.32.222>;tag=as210de787
To: <sip:11@192.168.32.104:2063;line=4dbo4cqy>
Contact: <sip:asterisk@192.168.32.222>
Call-ID: 295840357e4fac9b5627d28b53622155@192.168.32.222
CSeq: 102 NOTIFY
User-Agent: Asterisk PBX
Max-Forwards: 70
Event: message-summary
Content-Type: application/simple-message-summary
Content-Length: 95

Messages-Waiting: yes
Message-Account: sip:asterisk@192.168.32.222
Voice-Message: 1/0 (0/0)


Can anyone offer any suggestions as to why the Message-Account is set to Asterisk and not 511@192.168.32.222 ???

In my voicemail.conf i have :-

[xxx-voicemail]
515 => PasswordHere,Name,EmailHere
511 => PasswordHere,Name,EmailHere

I have been pulling my hair out for hours and cant see why it would be doing it. Maybe someone can see something obvious i have wrong.

Thanks in advance
danielkelly
Oldsterisk
 
Posts: 51
Joined: Tue Nov 28, 2006 6:01 pm

Postby baconbuttie » Tue Apr 03, 2007 11:30 pm

i think it's a commonly reported issue with 360s ... i've never really got into changing the Snom's behaviour .. it's been simple enough to either reprogram the VM button to an extension i have defined, or create an "asterisk" extension that connects to the VM box for the callerid(num).
baconbuttie
Moves Like Spencer
 
Posts: 2657
Joined: Tue May 16, 2006 6:32 am
Location: Forest of Dean, Gloucestershire, UK.

Postby engjohn » Wed Apr 04, 2007 9:11 am

just add this to your config...

exten => asterisk,1,VoiceMailMain(${CALLERIDNUM})
engjohn
Newsterisk
 
Posts: 2
Joined: Wed Aug 02, 2006 9:21 am


Return to Asterisk Support

Who is online

Users browsing this forum: Exabot [Bot], Google [Bot], Majestic-12 [Bot] and 1 guest