RESOLVED: dahdi doesn't start on boot

Get help with installing, upgrading and running Asterisk.

Moderators: muppetmaster, Moderator, Support

RESOLVED: dahdi doesn't start on boot

Postby pmlco » Sat Dec 06, 2008 1:51 pm

Hello. I have recently switched to dahdi and Asterisk 1.6.0-rc6. I have a TDM410P. Everything seems fine, except that when I reboot the system, dahdi doesn't start, I have to do it manually with /etc/init.d/dahdi start. Then all is well. On booting, a console message complains about /dev/dahdi/1 not existing, which indeed it doesn't
pbx:~# ls /dev/dahdi/
channel ctl pseudo timer

until I start dahdi

pbx:~# /etc/init.d/dahdi start
Loading DAHDI hardware modules:
wctdm24xxp: done
Running dahdi_cfg: done.
pbx:~# ls /dev/dahdi/
1 2 3 4 channel ctl pseudo timer

Any ideas?
Ian.
Last edited by pmlco on Sun Dec 07, 2008 10:48 am, edited 1 time in total.
pmlco
Oldsterisk
 
Posts: 232
Joined: Sun Apr 06, 2008 3:56 am

RESOLVED: dahdi doesn't start on boot

Postby pmlco » Sun Dec 07, 2008 10:45 am

The module wctdm24xxp should have been loaded in /etc/init.d/dahdi:

Code: Select all
if [ $system = debian ]; then
                        echo -n "   ${line}: "
                        if modprobe $line 2> /dev/null; then
                                echo -n "done"
                        else
                                echo -n "error"
                        fi

However, this was failing with the error:
Code: Select all
WARNING: Not loading blacklisted module wctdm24xxp


So I had to remove wctdm24xxp from /etc/modprobe.d/dahdi.blacklist. Now it loads correctly on system boot.

Ian.
pmlco
Oldsterisk
 
Posts: 232
Joined: Sun Apr 06, 2008 3:56 am


Return to Asterisk Support

Who is online

Users browsing this forum: No registered users and 1 guest